Bug 1029422 - oo-install should support user set up activemq replicants and datastore replicants.
oo-install should support user set up activemq replicants and datastore repli...
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
2.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 06:28 EST by Johnny Liu
Modified: 2017-03-08 12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 09:15:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2013-11-12 06:28:06 EST
Description of problem:
Currently openshift.sh support user export CONF_ACTIVEMQ_REPLICANTS and CONF_DATASTORE_REPLICANTS to set up activemq and datastore replicants, but oo-install tools still not support yet, it should be enabled.

Version-Release number of selected component (if applicable):
oo-install-ose-2.0b-20131111-2053

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Johnny Liu 2013-11-13 06:14:46 EST
Looks like datastore replicants can not be set up totally automatically, while activemq replicants could. So change the summary.
Comment 3 Miciah Dashiel Butler Masters 2013-11-13 10:34:40 EST
CONF_DATASTORE_REPLICANTS should totally automate configuration of datastore replicants.  Is there a bug report for its failure to do so?
Comment 4 Brenton Leanhardt 2013-11-13 10:42:23 EST
I think the bug is that currently oo-install's OSE workflow never asks the user if they would like to set that value.  This could simply be something we don't support for now given that oo-install main focus for OSE is configuring demos environments right now.
Comment 5 Miciah Dashiel Butler Masters 2013-11-13 10:44:13 EST
Does oo-install's OSE workflow ask the user if they would like to set the value for ActiveMQ replicants then?
Comment 6 Brenton Leanhardt 2013-11-13 10:48:04 EST
To my knowledge all of the default values in openshift.sh are assumed.
Comment 7 Johnny Liu 2013-11-13 21:11:11 EST
(In reply to Miciah Dashiel Butler Masters from comment #3)
> CONF_DATASTORE_REPLICANTS should totally automate configuration of datastore
> replicants.  Is there a bug report for its failure to do so?

Check openshift.sh, you will see the following codes:
configure_datastore()
{
  <--snp-->
  if ! [[ ${datastore_replicants} =~ , ]]
  then
    # This mongod will _not_ be part of a replicated setup.
    configure_datastore_add_users
  fi

}

That means user need do "configure_datastore_add_users" manually when datastore replicants is set if my understanding is right.
Comment 8 Johnny Liu 2013-11-13 21:14:16 EST
(In reply to Miciah Dashiel Butler Masters from comment #5)
> Does oo-install's OSE workflow ask the user if they would like to set the
> value for ActiveMQ replicants then?

No, oo-install's OSE workflow does not ask user currently, that is the point of this bug.
Comment 9 Miciah Dashiel Butler Masters 2013-11-13 21:23:38 EST
Ah, yes, one must run (for example) `openshift.sh datastore_replicants=datastore01.example.com,datastore02.example.com,datastore03.example.com actions=configure_datastore_add_replicants,configure_datastore_add_users` on one of the replicants after they are all installed and running.
Comment 10 Luke Meyer 2013-11-19 09:15:02 EST
This feature is captured in a Trello card:

https://trello.com/c/f4T9Amo5

Note You need to log in before you can comment on or make changes to this bug.