Bug 1029427 - Entry-field properties not stored
Entry-field properties not stored
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER5
: 6.0.0
Assigned To: Neus Miras
Tomas Livora
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 06:34 EST by Patrick Steiner
Modified: 2013-12-02 07:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 13464, Getting Started Guide-6-Beta-1 Build Date: 13-09-2013 14:51:49 Topic ID: 21439-490408 [Latest]
Last Closed: 2013-12-02 07:54:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Steiner 2013-11-12 06:34:23 EST
Title: Entry-field properties not stored

Describe the issue:
When creating a new form with the GUI Designer, I would like to have some of the fields to be read-only. To do so, I can change the properties of the field by selecting it's "Edit" icon.
If I then select the "read only" checkbox, safe the changes and after that close and re-open the properties, the previously selected "read only" is again unchecked.
The form also behaves with the fields to be read/write so it is not only a matter of not storing the right value. 


Suggestions for improvement:
Fix


Additional information:
Comment 2 Neus Miras 2013-11-13 10:17:29 EST
I was trying to reproduce the behaviour reported, but I couldn't.

I created a new form, and added properties of different types. I accessed to one field properties usind the edit button over the field and the edit field properties is displayed. I check the read only and click save, after that the field properties window disappears. Once I try to access the field properties again, the read only check is checked. 

Did I missed something in my test, can you help me to reproduce it?
Thanks in advanced.
Comment 3 Patrick Steiner 2013-11-13 10:54:00 EST
My error! Sorry!

Due to screen resultion I was not aware that there is a "save" button inside the properties dialog.

Saying this, wouldn't it increase usability if a user would be informed that he is about to leave the page without saving his changes?

Regards

Patrick
Comment 4 Tomas Livora 2013-12-02 07:54:25 EST
According to the discussion above it is not a bug. There are just two Save buttons - one for the field properties and one for the entire form.

Note You need to log in before you can comment on or make changes to this bug.