Bug 1029428 - page file should not be executable
page file should not be executable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
3.0
Unspecified Unspecified
medium Severity unspecified
: 3.0
: ---
Assigned To: Gordon Sim
Eric Sammons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 06:35 EST by Gordon Sim
Modified: 2015-01-21 07:56 EST (History)
3 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 07:56:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5309 None None None Never

  None (edit)
Description Gordon Sim 2013-11-12 06:35:05 EST
Description of problem:

The page file created for a paged queue has the executable permission set which it shouldn't since its not an executable file.

Version-Release number of selected component (if applicable):

Early Access

How reproducible:

100%

Steps to Reproduce:
1. start broker with --data-dir <some-path>
2. qpid-config add queue --argument qpid.paging=True
3. ls -l <some-path>

Actual results:

Executable permission is set (e.g. -rwx------)

Expected results:

Executable permission is not set (e.g -rw-------)

Additional info:
Comment 1 Gordon Sim 2013-11-12 06:35:51 EST
Fixed upstream: https://svn.apache.org/r1540039
Comment 2 Leonid Zhaldybin 2014-01-29 05:26:43 EST
Tested on RHEL6.5 (both i386 and x86_64). This issue has been fixed.

Packages used for testing:

python-qpid-0.22-10.el6
python-qpid-qmf-0.22-26.el6
qpid-cpp-client-0.22-33.el6
qpid-cpp-client-devel-0.22-33.el6
qpid-cpp-client-devel-docs-0.22-33.el6
qpid-cpp-client-rdma-0.22-33.el6
qpid-cpp-client-ssl-0.22-33.el6
qpid-cpp-server-0.22-33.el6
qpid-cpp-server-devel-0.22-33.el6
qpid-cpp-server-ha-0.22-33.el6
qpid-cpp-server-linearstore-0.22-33.el6
qpid-cpp-server-rdma-0.22-33.el6
qpid-cpp-server-ssl-0.22-33.el6
qpid-cpp-server-xml-0.22-33.el6
qpid-java-client-0.22-5.el6
qpid-java-common-0.22-5.el6
qpid-java-example-0.22-5.el6
qpid-jca-0.22-1.el6
qpid-jca-xarecovery-0.22-1.el6
qpid-jca-zip-0.22-1.el6
qpid-proton-c-0.6-1.el6
qpid-qmf-0.22-26.el6
qpid-qmf-devel-0.22-26.el6
qpid-tests-0.22-12.el6
qpid-tools-0.22-7.el6
rh-qpid-cpp-tests-0.22-33.el6
ruby-qpid-qmf-0.22-26.el6

-> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.