Bug 1029433 - jbpm-designer-standalone.war does not deploy in EAP 6.1
jbpm-designer-standalone.war does not deploy in EAP 6.1
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Linux
medium Severity medium
: ER6
: 6.0.0
Assigned To: Pere Fernàndez
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 06:42 EST by Jorge Perez Bolano
Modified: 2014-08-06 16:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:13:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jorge Perez Bolano 2013-11-12 06:42:57 EST
jbpm-designer-standalone-6.0.0.Final.war does not deploy in EAP 6.1

Trying to deploy jbpm-designer-standalone-6.0.0.Final.war in EAP 6.1, the following error arises:

12:22:49,742 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015876: Starting deployment of "jbpm-designer-standalone-6.0.0.Final.war" (runtime-name: "jbpm-designer-standalone-6.0.0.Final.war")
12:22:57,111 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xml-apis-1.0.b2.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jbpmmigration-0.11.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,111 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry log4j-1.2.16.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jbpmmigration-0.11.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,117 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jaxb-api.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jaxb-impl-2.2.5.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,117 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry activation.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jaxb-impl-2.2.5.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,117 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jsr173_1.0_api.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jaxb-impl-2.2.5.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,117 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jaxb1-impl.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jaxb-impl-2.2.5.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,119 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry avalon-framework-4.2.0.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,120 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry batik-all-1.7.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,120 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry commons-io-1.3.1.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,120 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry serializer-2.7.0.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,120 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry servlet-2.2.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,120 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xalan-2.7.0.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,120 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xercesImpl-2.7.1.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,121 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xml-apis-ext-1.3.04.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,121 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xmlgraphics-commons-1.3.1.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,121 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry fop-hyph.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,121 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jai_codec.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,121 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jai_core.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,122 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jai_imageio.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,122 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jimi-1.0.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,122 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xmlunit1.0.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,122 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xercesImpl.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/xalan-2.7.1.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,123 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xml-apis.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/xalan-2.7.1.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,123 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry serializer.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/xalan-2.7.1.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,123 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xml-apis.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/serializer-2.7.1.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,137 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jaxb-api.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jaxb-xjc-2.2.5.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,138 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jaxb-impl.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jaxb-xjc-2.2.5.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,138 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jsr173_1.0_api.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jaxb-xjc-2.2.5.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,138 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry activation.jar in /content/jbpm-designer-standalone-6.0.0.Final.war/WEB-INF/lib/jaxb-xjc-2.2.5.jar  does not point to a valid jar for a Class-Path reference.
12:22:57,200 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015893: Encountered invalid class name 'org.xmlpull.mxp1.MXParser,org.xmlpull.mxp1_serializer.MXSerializer' for service type 'org.xmlpull.v1.XmlPullParserFactory'
12:22:57,201 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015893: Encountered invalid class name 'org.xmlpull.mxp1.MXParser,org.xmlpull.mxp1_serializer.MXSerializer' for service type 'org.xmlpull.v1.XmlPullParserFactory'
12:22:57,201 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015893: Encountered invalid class name 'org.springframework.context.ApplicationContext,org.springframework.beans.BeansException,org.springframework.beans.factory.xml.NamespaceHandlerResolver' for service type 'org.apache.cxf.bus.factory'
12:22:57,206 INFO  [org.jboss.as.pojo] (MSC service thread 1-5) JBAS017000: Found legacy bean/pojo namespace: urn:jboss:bean-deployer:2.0 - might be missing some xml features (potential exceptions).
12:22:57,675 INFO  [org.jboss.weld.deployer] (MSC service thread 1-8) JBAS016002: Processing weld deployment jbpm-designer-standalone-6.0.0.Final.war
12:22:58,009 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-2) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)
12:22:58,011 INFO  [org.jboss.weld.deployer] (MSC service thread 1-2) JBAS016005: Starting Services for CDI deployment: jbpm-designer-standalone-6.0.0.Final.war
12:22:58,042 INFO  [org.jboss.weld.deployer] (MSC service thread 1-8) JBAS016008: Starting weld service for deployment jbpm-designer-standalone-6.0.0.Final.war
12:22:58,325 ERROR [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS015870: Deploy of deployment "jbpm-designer-standalone-6.0.0.Final.war" was rolled back with the following failure message: {"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.naming.context.java.module.\"jbpm-designer-standalone-6.0.0.Final\".\"jbpm-designer-standalone-6.0.0.Final\".env.ErraiService is missing [jboss.naming.context.java.jboss.resources.ErraiService]"]}
12:22:58,341 INFO  [org.jboss.weld.deployer] (MSC service thread 1-3) JBAS016009: Stopping weld service for deployment jbpm-designer-standalone-6.0.0.Final.war
12:22:58,565 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-7) JBAS015877: Stopped deployment jbpm-designer-standalone-6.0.0.Final.war (runtime-name: jbpm-designer-standalone-6.0.0.Final.war) in 238ms

This WAR will be useful to the Freemodeler project.

I'm using the final community version.
Comment 2 Pere Fernàndez 2013-11-26 06:00:25 EST
You were using the wrong war. You must compile the jbpm-designer-distribution-wars modules and use the jbpm-designer-standalone-jboss-as7.0.war
Comment 3 Marek Baluch 2013-12-21 11:13:24 EST
This is a community issue not related to the product. Closing as VERIFIED as I was not able to reproduce the about anymore.

Note You need to log in before you can comment on or make changes to this bug.