Bug 1029463 - [RHSC] 'Stopped At' field is not getting displayed in the remove-brick status dialog when remove-brick is stopped.
[RHSC] 'Stopped At' field is not getting displayed in the remove-brick status...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: ---
: RHGS 2.1.2
Assigned To: anmol babu
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 07:39 EST by Shruti Sampat
Modified: 2015-05-13 12:34 EDT (History)
8 users (show)

See Also:
Fixed In Version: cb9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 03:03:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20800 None None None Never

  None (edit)
Description Shruti Sampat 2013-11-12 07:39:55 EST
Description of problem:
-----------------------
When remove-brick operation on a volume is stopped from the UI, the status dialog is supposed to show a field 'Stopped At' that shows the time when remove-brick was stopped. This field is not getting displayed.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.23.master.el6_5 

How reproducible:
Always

Steps to Reproduce:
1. Start remove-brick on a volume.
2. Stop the remove-brick operation from the Console.

Actual results:
The status dialog does not display the 'Stopped At' field.

Expected results:
The status dialog should display the stopped at field.

Additional info:
Comment 2 Shruti Sampat 2013-11-26 04:16:23 EST
Hi Anmol,

When remove-brick operation is stopped on a volume, using the Stop button in the status dialog, the fields 'Cluster' and 'Status At' can be seen shifting towards the right, when the 'Stopped At' field appears in the center. Can the 'Cluster' and 'Status At' field not be arranged in such a way, that if the operation is stopped, they don't have to be shifted to the right to make space for the 'Stopped At' to be displayed?
Comment 3 anmol babu 2013-11-26 04:25:25 EST
Actually,there are 4 VPanels always but 2 are invisible depending on the condition. but even after conditionally setting just their visibility,that movement can be seen.Bcoz internally invisible items are treated as absent by the framework.
Comment 4 Shruti Sampat 2013-11-26 07:35:26 EST
Marking this bug a VERIFIED in Red Hat Storage Console Version: 2.1.2-0.25.master.el6_5 as per above comment. Will open a different BZ for the shift seen in the position of 'Cluster' and 'Status At' fields.
Comment 6 errata-xmlrpc 2014-02-25 03:03:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.