Bug 1029499 - Add a troubleshooting chapter to transactions subsection
Add a troubleshooting chapter to transactions subsection
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Russell Dickenson
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 08:51 EST by Ondrej Chaloupka
Modified: 2014-08-14 11:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14874, Administration and Configuration Guide-6.2-1 Build Date: 07-11-2013 09:29:23 Topic ID: 4374-459144 [Specified]
Last Closed: 2013-11-26 17:05:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Chaloupka 2013-11-12 08:51:23 EST
Title: Transactions Configuration Overview

Hi,

I want to ask for creating a troubleshooting section for Transaction subsystem in documentation. We were solving one bz (https://bugzilla.redhat.com/show_bug.cgi?id=1009981) which causes a log being filled with warning messages.
Information about configuration of the AS server should be documented.

The text came from the bz1009981

Description: 
When machine is under bigger load of the receiving messages there could happen the server log would contain XAException from Periodic Recovery of rollbacking a transaction.
We hit this for HornetQ but this is supposed to happen for any messaging system used under EAP.

The transaction is in fact not rollbacked at all. The commit is done but meanwhile the Periodic Recovery process comes into play. The scenario is described by Tom in the comment:
https://bugzilla.redhat.com/show_bug.cgi?id=1009981#c6

Cause:
The transaction handling and periodic recovery are two independent threads which access a same transaction record. 
The RAR informs periodic recovery about not commited transaction and tries to recover it but meanwhile the RAR procceed with the commit.

Consequence: 
Log could contains XAException which informs about fail to rollback a transaction by Periodic Recovery. But in fact there was no rollback and all messages were correctly received and commited.

Fix: 
There isn't any generic fix possible being done in Narayana code. When the problem occurs it's recommended to increase interval between the two phases of the recovery process. Use property
com.arjuna.ats.jta.orphanSafetyInterval 
at the start of the EAP server and set it to the bigger number than the 10000 milliseconds which is default value.

Result:
Use com.arjuna.ats.jta.orphanSafetyInterval property when problem occurs.

Thank you
Comment 1 Russell Dickenson 2013-11-25 20:19:41 EST
Attention: Ondrej

I'm not quite sure just what you're asking be added to the Admin & Config Guide. When I read over this BZ ticket and BZ1009981 it looks as if this is something that should be mentioned in the Release Notes. Perhaps I misunderstand and the issue is more complex.

Can you please explain further?
Comment 2 Ondrej Chaloupka 2013-11-26 03:19:06 EST
Hi Russel,

you are right. This should be put to Release Notes.

My prior intention (or the reason why I asked to add it to config guide) was to inform user about some configuration option that could solve some problems.

But I agree with you that this should be put rather to release notes.

I'm sorry for confusions

Thanks 
Ondra
Comment 3 Ondrej Chaloupka 2013-11-26 08:35:41 EST
I've slightly changed the doc text in the https://bugzilla.redhat.com/show_bug.cgi?id=1009981
Comment 4 Russell Dickenson 2013-11-26 17:05:52 EST
I have closed this BZ ticket as Ondrej and I have agreed that a release notes entry is all that is required. The RN entry has been made in the parent of this BZ ticket, BZ1009981.

Note You need to log in before you can comment on or make changes to this bug.