Bug 1029506 - AFR: “volume heal newvolume full” recover file -- deleted file not copy from carbon node
AFR: “volume heal newvolume full” recover file -- deleted file not copy from ...
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.4.1
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 09:00 EST by huangchongyuan
Modified: 2014-01-03 03:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 03:54:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description huangchongyuan 2013-11-12 09:00:11 EST
Description of problem:
AFR volume: create a AFR volume, and then change a file in one brick (just add a row, so it is a wrong file).I delete this wrong file in this brick, and then execute "gluster volume heal afr_full". Guess what? yes,it recover a file in this brick, but ... this file is a wrong file(changed by me),not a copy from carbon node. why ? 

Version-Release number of selected component (if applicable):
3.4.1 & 3.3.2

How reproducible:
always and I have test many times

Steps to Reproduce:
1.create a AFR volume : afr_vol
2.change a file in one brick (just add a row)
3.gluster volume heal afr_vol full
4.recover a file (changed by me,not a copy from carbon node)

Actual results:
this file is the file which changed by me

Expected results:
recover a normal file (copy from other node)

Additional info:
so why?
Comment 1 Pranith Kumar K 2014-01-03 03:54:52 EST
Files on bricks should not be modified directly. Marking this as not a bug

Note You need to log in before you can comment on or make changes to this bug.