Bug 1029546 - Version history: widget not wide enough
Version history: widget not wide enough
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER1
: 6.0.1
Assigned To: Alexandre Porcelli
Tomas David
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 10:01 EST by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 15:59:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (46.93 KB, image/png)
2013-11-12 10:01 EST, Zuzana Krejčová
no flags Details
New screenshot (23.87 KB, image/png)
2013-12-13 08:51 EST, Tomas David
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-11-12 10:01:38 EST
Created attachment 823015 [details]
screenshot

Description of problem:
The Version history widget in Metadata tab is not wide enough and cannot be scrolled sideways. Some commit messages cannot be read as a result - a good example being the default commit message when you delete a file.
There is enough space on the page, as can be seen in the screenshot, the widget takes only about half the space available and leaves the rest blank.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER4
Comment 2 manstis 2013-11-12 16:11:37 EST
You might need to clear your browser cache; as a CSS file has been modified.
Comment 3 Tomas David 2013-12-13 08:47:09 EST
The widget is now wider, but some longer commit messages (on displays with smaller resolutions) still cannot be read and horizontal scrollbar doesn't appear.
Comment 4 Tomas David 2013-12-13 08:51:07 EST
Created attachment 836332 [details]
New screenshot
Comment 6 Alexandre Porcelli 2014-01-17 12:19:31 EST
This doesn't fix the issue as it's more complicate that seems to be (HTML select element doesn't support horizontal scroll) but adding a title to the OPTION element gives users a `tool-tip` with all content. 

Very likely that not just this component but all metadata should be improved soon in order to get aligned with recent UI changes in the near future (keep in mind this is just a port of old guvnor)

(6.0.x) http://github.com/droolsjbpm/kie-wb-common/commit/359ceb168
(master) http://github.com/droolsjbpm/kie-wb-common/commit/25f7ed0ca
Comment 7 Lukáš Petrovický 2014-02-07 11:19:58 EST
This no longer has a target release of 6.0.0.
Comment 8 Tomas David 2014-02-18 05:53:26 EST
Verified on BRMS 6.0.1.ER1.

Note You need to log in before you can comment on or make changes to this bug.