Bug 1029571 - NM disptcher script is unable to get global DNS servers
NM disptcher script is unable to get global DNS servers
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnssec-trigger (Show other bugs)
20
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 10:57 EST by Tomáš Hozza
Modified: 2013-12-13 22:48 EST (History)
3 users (show)

See Also:
Fixed In Version: dnssec-trigger-0.11-15.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 22:48:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Hozza 2013-11-12 10:57:55 EST
Description of problem:
dnssec-trigger NM dispatcher script is unable to get global DNS
servers using nmcli, because nmcli syntax changed in NM >= 0.9.9.0

Version-Release number of selected component (if applicable):
dnssec-trigger-0.11-14.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1. install dnssec-trigger
2. start dnssec-trigger
3. check journal

Actual results:
Nov 12 16:55:40 client123.example3.com logger[1620]: dnssec-trigger-hook(networkmanager)   added global DNS

Expected results:
Nov 12 16:55:40 client123.example3.com logger[1620]: dnssec-trigger-hook(networkmanager)   added global DNS <ip address>

Additional info:
https://open.nlnetlabs.nl/pipermail/dnssec-trigger/2013-November/000226.html
Comment 1 Fedora Update System 2013-11-13 02:58:22 EST
dnssec-trigger-0.11-15.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnssec-trigger-0.11-15.fc20
Comment 2 Fedora Update System 2013-11-13 22:39:30 EST
Package dnssec-trigger-0.11-15.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnssec-trigger-0.11-15.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21304/dnssec-trigger-0.11-15.fc20
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-12-13 22:48:18 EST
dnssec-trigger-0.11-15.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.