Bug 1029619 - x230 tablet's stylus and touchscreen incorrectly mapped to second monitor
x230 tablet's stylus and touchscreen incorrectly mapped to second monitor
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-settings-daemon (Show other bugs)
7.0
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Rui Matos
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 13:21 EST by Michael Boisvert
Modified: 2017-07-03 11:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 10:36:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Boisvert 2013-11-12 13:21:34 EST
Description of problem:

When using the x230t with a second monitor attached, the stylus and touchscreen movements on the display are incorrectly placed entirely on the second monitor. This occurs when the second display is being used to extend the desktop.

How reproducible: Always

Steps to Reproduce:
1. Install RHEL7.0 on the x230t.
2. Plug in second monitor.
3. Try using the stylus or touchscreen on the x230t's display.

Actual results: All movements are placed on the second monitor, not the tablets display.

Expected results: The stylus and touchscreen only operate on the x230t's built in display.
Comment 1 Peter Hutterer 2013-12-10 20:34:32 EST
Can you confirm this is still an issue? And if so, can you please post the product ID of the device? Thanks. The Wacom section in /proc/bus/input/devices will do.
Comment 2 Michael Boisvert 2013-12-16 10:42:09 EST
I: Bus=0003 Vendor=056a Product=00e6 Version=0139
N: Name="Wacom ISDv4 E6 Pen"
P: Phys=
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.0/input/input9
U: Uniq=
H: Handlers=mouse2 event9 
B: PROP=2
B: EV=b
B: KEY=1c03 0 0 0 0 0
B: ABS=1000003

I: Bus=0003 Vendor=056a Product=00e6 Version=0139
N: Name="Wacom ISDv4 E6 Finger"
P: Phys=
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.1/input/input10
U: Uniq=
H: Handlers=mouse3 event10 
B: PROP=2
B: EV=b
B: KEY=400 0 0 0 0 0
B: ABS=260800000000003

The problem is still occurring with both the stylus and touch.
Comment 3 Peter Hutterer 2014-02-04 22:28:14 EST
Carlos, what's going on here, can you have a look please? This bit is controlled by g-s-d.
Comment 4 Carlos Garnacho 2014-02-05 14:31:24 EST
I've just attached some patches on the upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=709600 that will fix this and other issues like bug #1029612.

On that other bug I was pondering that the wacom module changes are maybe too invasive, although seeing this other bug, maybe it is worth to have something unified here.
Comment 5 Peter Hutterer 2014-02-12 02:13:38 EST
Moving this over to g-s-d as per comment #4.
Comment 6 Bastien Nocera 2014-02-18 02:34:18 EST
(In reply to Carlos Garnacho from comment #4)
> I've just attached some patches on the upstream bug
> https://bugzilla.gnome.org/show_bug.cgi?id=709600 that will fix this and
> other issues like bug #1029612.
> 
> On that other bug I was pondering that the wacom module changes are maybe
> too invasive, although seeing this other bug, maybe it is worth to have
> something unified here.

I'm fine backporting the fixes, but I think that we should make the changes upstream first. Let's handle this upstream first (and land it in 3.8 and 3.10), and target 7.1 to make sure that the changes aren't causing major regressions.
Comment 11 Michael Boisvert 2015-08-20 15:51:34 EDT
During testing of 7.2 Prebeta, I noticed this issue is no longer present. I believe this can be closed as current release, unless we want to wait until the actual beta.
Comment 12 Matthias Clasen 2016-01-29 10:36:55 EST
closing, according to comment 11

Note You need to log in before you can comment on or make changes to this bug.