Bug 1029724 - RHN page missed proxy server/port info after registered RHN with proxy
RHN page missed proxy server/port info after registered RHN with proxy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.5.0
Assigned To: Ryan Barry
Virtualization Bugs
node
: Regression, ZStream
Depends On: 1150377
Blocks: 1063976 1123329 rhev3.5beta 1156165
  Show dependency treegraph
 
Reported: 2013-11-12 21:25 EST by haiyang,dong
Modified: 2016-02-10 15:07 EST (History)
17 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-18.el6.7
Doc Type: Bug Fix
Doc Text:
After successfully registering with the Red Hat Network and selecting "RHN" The page was not displaying the proxy server/port information. The page now shows this information.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-11 15:47:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for RHN Registration.png (62.29 KB, image/png)
2013-11-12 21:25 EST, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 30433 master ABANDONED Fix missed proxy server/port info in TUI issue Never
oVirt gerrit 30451 master ABANDONED Also handle proxy server like "http://ip:port" Never

  None (edit)
Description haiyang,dong 2013-11-12 21:25:39 EST
Created attachment 823235 [details]
attached Screenshot for RHN Registration.png

Description of problem:
Registered RHN with http proxy, after registered it successfully, option "RHN" was selected
,Registration status display "RHN" and 
But the field of HTTP Proxy didn't show proxy server/port info, only shown proxy username/password info.
(Seen RHN Registration.png)

Version-Release number of selected component (if applicable):
rhevh-6.5-20131031.1.0
ovirt-node-3.0.1-7.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install the rhevh-6.5-20131031.1.0
2. Registered to RHN with proxy.
3. Focus on the page of "RHN Registration".

Actual results:
RHN page missed proxy server/port info after registered RHN with proxy 

Expected results:
RHN page missed proxy info after registered RHN with proxy 

Additional info:
no this issue in rhevh 6.4.z, so it's a regression bug
Comment 5 Cheryn Tan 2014-01-08 00:35:48 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 6 haiyang,dong 2014-01-13 22:19:33 EST
Test version:
ovirt-node-3.0.1-16.el6_5.noarch.rpm
rhevh-6.5-20140110.1

when using proxy server like "ip:port",
RHN page will show proxy server/port info after registered RHN with proxy

but
when using proxy server like "http://ip:port",
RHN page still missed proxy server/port info after registered RHN with proxy.

so this bug only fix partly, need to re-assign it.
Comment 15 haiyang,dong 2014-11-12 23:05:55 EST
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

to test follow cases:
(a)registered RHN with http proxy server like "ip:port"
(b)registered RHN with http proxy server like "http:
//ip:port"

Test result:
the field of HTTP Proxy always show proxy server/port
info when registered RHN with http proxy server like "ip:port" or "http:
//ip:port"

so this bug has been fixed in in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED"
Comment 17 errata-xmlrpc 2015-02-11 15:47:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html

Note You need to log in before you can comment on or make changes to this bug.