Bug 1029759 - Impossible to delete data providers on MAC OS X
Impossible to delete data providers on MAC OS X
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: David Gutierrez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 01:44 EST by Jan Hrcek
Modified: 2014-03-19 10:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 02:51:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Steps to reproduce - video (8.93 MB, video/webm)
2013-11-13 01:44 EST, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-11-13 01:44:40 EST
Created attachment 823258 [details]
Steps to reproduce - video

Description of problem:
When on MAC OS - in firefox, the buttons for deleting data providers don't do anything (the other buttons work, e.g. for editing data provider properties)

Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER4
MAC OS X version 10.7.3
Firefox 17

How reproducible:
Always

Steps to Reproduce:
1. I open the dashbuilder in firefox on MAC OS 
2. I navigate to workspace Showcase, page Data providers
3. I click the 'trash' (Delete data provider) icon for some data provider

Actual results:
Nothing happens 
- no dialog is popped up (with message that data provider is used in some KPIs)
- data provider is not deleted

Expected results:
The delete button should work as on other platforms:
1) when no KPIs using the provider exist, the data provider should be deleted
2) when there are KPIs using the provider, the alert "Can't delete provider because it is used in X KPIs" should be displayed (as was implemented in fix for https://bugzilla.redhat.com/show_bug.cgi?id=962681)

Additional info:
I also tried deleting my custom created data provider, which was not used in any KPIs - the problem was the same - nothing could be deleted, no feedback in UI.

I recorder video showing the problem.
In video I first try to delete the provider in MAC OS - doesn't work (note, that other buttons work - for example in video I click Edit provider properties) then I switch to fedora 19 + firefox 17 and it works as expected - alert is displayed that provider can't be deleted.
Comment 1 Jan Hrcek 2013-11-13 02:51:53 EST
I'am sorry it's not a bug, it's working correctly. As it turns out, the MAC computer had a setting in firefox that blocks all popups (alerts) enabled. After disabling it the the alert 'Can't delete provider because ...' appeared correctly.

Please disregard this bugzilla. Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.