Bug 1029768 - Documentation bug: the description of the relative-to and object-store-relative-to attributes are wrong.
Documentation bug: the description of the relative-to and object-store-relat...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.1
All All
unspecified Severity low
: GA
: EAP 6.3.0
Assigned To: Lucas Costi
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 02:20 EST by Kenjiro Nakayama
Modified: 2014-08-14 11:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.12 Build Name: 19233, Administration and Configuration Guide-6.1-1 Build Date: 05-09-2013 10:36:48 Topic ID: 4310-459145 [Specified]
Last Closed: 2014-03-31 08:45:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2013-11-13 02:20:49 EST
Title: Configure the Transaction Manager

Describe the issue:

In Table 18.1. TM Configuration Options, The description of Relative to is wrong. It says "Use an empty string to disable the default behavior and force the value of the path attribute to be treated as an absolute path." but this sentence is wrong. If the attribute of relative-to sets empty string, it will be error with following message.


[standalone@localhost:9999 /] /subsystem=transactions/:write-attribute(name=relative-to,value="")
{
    "outcome" => "failed",
    "failure-description" => "JBAS014704: '' is an invalid value for parameter relative-to. Values must have a minimum length of 1 characters",
    "rolled-back" => true
}

Suggestions for improvement:

* current
Use an empty string to disable the default behavior and force the value of the path attribute to be treated as an absolute path.

* tobe
(The sentence should be deleted.)
Comment 1 Kenjiro Nakayama 2013-11-13 23:21:54 EST
The description of object-store-relative-to is wrong too. 

[standalone@localhost:9999 /] /subsystem=transactions/:write-attribute(name=object-store-relative-to,value="")
{
    "outcome" => "failed",
    "failure-description" => "JBAS014704: '' is an invalid value for parameter object-store-relative-to. Values must have a minimum length of 1 characters",
    "rolled-back" => true
}

The documentations should be correct.
Comment 2 Lucas Costi 2014-01-13 00:09:48 EST
Tom, jlivings said you might be able to help out on this:

Could you please confirm that the above is the intended behaviour? It looks like a null value might be accepted rather than an empty string, so should the docs be changed to reflect that, or should those sentences be removed as suggested by Kenjiro?

Thanks
Comment 3 tom.jenkinson 2014-01-14 11:03:33 EST
relative-to looks like it was added to be consistent with other services in the application server. If that feature is now solely present in transactions I would be happy to remove the feature from the subsystem entirely. 

Put another way, relative-to is not used by the transaction manager itself, it is purely to be consistent with setting file paths in WildFly/AS7 configurations and the behaviour should be the same as any other file path setting mechanism in the As.
Comment 4 Lucas Costi 2014-01-21 20:06:58 EST
Thanks Tom.

After looking at the 'relative-to' uses throughout other services, there is no mention of an empty string being acceptable, so it looks like the best approach would be to remove the "empty string" sentence as suggested by Kenjiro.

Changes made to topic 4310, rev 578952

The changes will be reflected in the next document build, and the status will be changed to ON_QA when it is ready for review.
Comment 6 Ondrej Chaloupka 2014-02-17 05:14:34 EST
Verified. The incorrect point about relative-to is removed.
Comment 7 Kenjiro Nakayama 2014-03-31 08:45:02 EDT
Thanks! Closed.

Note You need to log in before you can comment on or make changes to this bug.