Bug 1029922 - Error when navigating to s-ramp-ui from external location
Error when navigating to s-ramp-ui from external location
Status: CLOSED DUPLICATE of bug 1035321
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kurt T Stam
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 09:25 EST by Stefan Bunciak
Modified: 2015-08-02 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 11:39:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Bunciak 2013-11-13 09:25:28 EST
Description of problem:

Error searching for artifacts.
java.net.ConnectException:Connection refused

org.overlord.sramp.client.SrampClientException: org.apache.http.conn.HttpHostConnectException: Connection to http://localhost:8080 refused

I know that I can set the url+ports in the config files to fix this, but is there a way how this can be automated? The benefit of eap that I can just specify the ip address when starting the server is lost in this case

Version-Release number of selected component (if applicable):
* 6.0.0.ER6

How reproducible:
* 100%

Steps to Reproduce:
1. start fsw on ip address different to localhost
2. navigate browser to the s-ramp-ui

Actual results:


Expected results:


Additional info:
* The same situation will occur also in dtgov,rtgov
Comment 2 Eric Wittmann 2013-12-16 11:07:18 EST
Kurt may have already fixed this.  Assigning to him (feel free to give it back if it's not fixed).
Comment 3 Kurt T Stam 2013-12-16 11:39:06 EST

*** This bug has been marked as a duplicate of bug 1035321 ***

Note You need to log in before you can comment on or make changes to this bug.