Bug 1029954 - updates section of gnome-software doesn't show updates
updates section of gnome-software doesn't show updates
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 10:32 EST by redhat
Modified: 2014-10-19 17:47 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-07 11:45:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat 2013-11-13 10:32:23 EST
Description of problem:
The Updates section on Gnome Software doesn't show any updates, even though updates are available when checking with 'yum check-update'.

Version-Release number of selected component (if applicable):
Gnome Software 3.10.3

How reproducible:
Easily reproducible.

Steps to Reproduce:
1. Clean install from live media iso
2. Check Updates section on Gnome Software
3. Check updates with 'yum check-update'

Actual results:
No updates show on the Updates section of Gnome Software.

Expected results:
The same updates that show on 'yum check-update' were expected to show on the Updates section of Gnome Software.

Additional info:
System updates detected and installed successfully using yum.
Comment 1 Finnbarr P. Murphy 2013-12-01 18:15:55 EST
I can confirm this bug. Only thing different is that I used Fedup to upgrade from F19 to F20;
Comment 2 Finnbarr P. Murphy 2013-12-01 23:54:06 EST
Update: After touching /var/lib/PackageKit/prepared-update, gnome-software updates worked for me.
Comment 3 redhat 2013-12-02 07:10:28 EST
I tried touching /var/lib/PackageKit/prepared-update with no success, this message appears on stdout with or without prepared-update.

(gnome-software:3459): Gs-WARNING **: failed to get updates: no results to show
Comment 4 redhat 2013-12-02 09:51:27 EST
Seems to be working now though. The warning message disappeared as well.
Comment 5 Richard Hughes 2013-12-10 05:13:08 EST
We only show updates when they are all downloaded, depsolved and ready to be installed. If a repo is in an unstable state, we don't show the updates as we can't get a coherent set.
Comment 6 jrb@redhat.com 2013-12-14 12:50:12 EST
I'm seeing this too with F20.  I've seen updates there previously, but now only show "software is up to date" available with the warning.  Can download/check/install updates from yum as per normal.
Comment 7 Jorge Fábregas 2013-12-30 16:42:55 EST
Same issue here on F20 (x86_64) as comment #6
Comment 8 cornel panceac 2014-01-07 08:51:56 EST
gnome-software says "Software is up to date" even if updates are listed in 'yum check-update'. This should be fixed. At least, there should be a message stating that "Updates exist and are processed. They will be displayed here only after everything is ready."
Comment 9 Thomas Meyer 2014-02-08 05:32:15 EST
Same here. What should I do to fix this problem?
Comment 10 Thomas Meyer 2014-02-09 05:18:58 EST
Hi all,

The problem with gnome-software is that it only show "prepared offline updates". The updates are prepared by a gnome component called "gnome-settings-daemon", which will every 24h check/download and prepare available updates. gnome-settings-daemon does this automatically and in the background.

You can force the download/preparation of offline updates via this terminal command: "$ pkcon update -d". this will download and prepare all available updates. After this command has finished you will see the available and prepared updates in gnome-software.

So this bug is not a bug, but rather the user has learned a different expectation in the past, but "$ pkcon update -d" will do the trick for most here, I guess.
Comment 11 Brian J. Murrell 2014-03-30 20:40:31 EDT
Just so I get this right: to use this GUI tool for updating software I first have to open a terminal and run:

$ pkcon update -d

Is it reasonable to expect everyone, including my mom to remember to do this to get updates?

I'm not sure I see how this is a step forward from the previous updating tool which did everything via the one tool.
Comment 12 Richard Hughes 2014-04-01 18:07:33 EDT
In 3.12 there's a manual refresh button to force getting the updates in the UI.
Comment 13 Aleksandar Kostadinov 2014-07-14 12:19:36 EDT
can we have a gnome independent mechanism for offline upating? `pkcon updates -d` followed by `pkcon offline-trigger` seems to do the job. But is hard to remember and no UI to remind you from time to time.
As a XFCE user I hope there is a better way than hooking everything into gnome.
Comment 14 Richard Hughes 2014-07-28 13:22:24 EDT
(In reply to Aleksandar Kostadinov from comment #13)
> can we have a gnome independent mechanism for offline upating? `pkcon
> updates -d` followed by `pkcon offline-trigger` seems to do the job. But is
> hard to remember and no UI to remind you from time to time.
> As a XFCE user I hope there is a better way than hooking everything into
> gnome.

I think XFCE has to build it's own PackageKit client UI if it doesn't want to use the GNOME UI.
Comment 15 Aleksandar Kostadinov 2014-07-28 13:48:19 EDT
The problem is not the UI. The problem is that it is gnome backend that periodically checks for updates.
Comment 16 Adam Williamson 2014-08-07 11:45:31 EDT
I don't believe there's anything specific left here that's fixable for F20; gnome-software in F21 improves the experience by letting you force the refresh, and the question of alternative clients for offline updates is interesting but not a bug for gnome-software. So I think it makes sense to close the bug at this point. If there are issues with updates in Fedora 21 it would be best to file them as new bugs to avoid confusion. Thanks!

Brian: you don't have to do that just to get updates, no. You have to do that if you know there are updates in the repos and you want them to show up in Software *right now*. The expectation behind the design is that users who update via Software don't necessarily need non-security updates to show up really fast; it isn't actually a problem if there's a delay before they appear (and in fact Software intentionally sets things up so non-critical updates show up periodically in a lump, not right away one piece at a time). And of course being able to do a refresh in the GUI helps in F21+.
Comment 17 Brian J. Murrell 2014-09-22 07:40:10 EDT
@Adam: except that gnome-software *never* shows updates until I hit the refresh button.

As an aside, gnome-software is a serious regression over gpk-update-viewer in terms of the number of clicks required to go through the updates and see what they are updating.  You first have to click on the OS Updates "section" and then for every update, click each one to open up a dialog to see what is being updated and then click a back button to go back to the list, to have to click again on another package name to see what is updated, etc.

And then there is no indication when you go back which one you clicked,

Additionally, if this is the new UI flow, it would be much more useful if all packages that had the same update reason were grouped together into a single item so that you click once for all of the packages that are in the same update reason.

But I digress -- into what is material for a new bug.
Comment 18 Brian J. Murrell 2014-09-22 07:41:00 EDT
Another digression, but another regression over gpk-update-viewer is that there is no way to get some OS updates but not be forced into taking them all.
Comment 19 Michael Convey 2014-10-19 17:47:10 EDT
This issue is problematic for anyone who is only on their computer occasionally. I have a number of computers and one of them I log into only occasionally. When I do, I want to be able to force an update while logged in. Unfortunately, I have to into a terminal and remember "pkcon update -d". This is a tedious mechanism that is not user friendly. Disappointing.

Note You need to log in before you can comment on or make changes to this bug.