Bug 102996 - Major problems on the new Compaq nx9010 laptop
Major problems on the new Compaq nx9010 laptop
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
http://freax.be/wiki/index.php/Instal...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-24 15:34 EDT by Philip Van Hoof
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Van Hoof 2003-08-24 15:34:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030807 Galeon/1.3.5

Description of problem:

There are major problems when installing RH 9 on a nx9010 Compaq Laptop. I have
identified a few of those problems on this wiki website and explained a
workaround the problems:

http://freax.be/wiki/index.php/Installing%20RH9%20on%20a%20Compaq%20nx9010%20laptop

It's possible for a real real real RH geek (like me) to get RH9 installed on
such a laptop, but not for a normal person.

Steps to get RH installed:

Disable all probing of any kind and disable usb and firewire support and probing
at the "boot:"-prompt.

First time you startup you will have to disable the firewire-module bypassing
kudzu, I did this using init=/bin/sh and then remounting root read-write and
removing the last line from modules.conf.

Then I booted in Interactive-mode to make sure that kudzu will not start, first
time I booted I disabled kudzu in the services. The Radeon was not detected so I
choosed the standard VGA-driver, the flatpane was also not detected but again
the standard one worked... 

The problems are, of course, when you plugin any USB device. However, plugging
in a (USB) mouse does work (and the mouse works too, also in the console)! (I
tried a logitech-one) but when I pull it out, everything hangs. 

Plugging in a memory-stick makes everything hang, pulling it out doesn't help
(only a hard reboot fixes the problem).

All these sound like major USB and Firewire problems for this laptop!

Also the Radeon "Mobile" GPU was not recognised. The network device and sound
where recognised and do work perfectly. Same for the DVD-rom and the CdWriter
device (cdrecord -scanbus displays a DVD with cdwriting capabilities).

I have not tested the firewire-ports



Version-Release number of selected component (if applicable):
Standard RH 9 version

How reproducible:
Always

Steps to Reproduce:
...

Additional info:
Comment 1 Philip Van Hoof 2003-08-31 12:19:55 EDT
More bugs about the PCMCIA-adapter and kudzu-bugs (kudzu makes the system hang)
have been explained on the website (workarounds).
Comment 2 Philip Van Hoof 2003-10-15 08:13:46 EDT
Joao Mendes reported on the same Wiki that if the modules.conf contains these
lines, stuff like firewire USB and PCMCIA works:

pre-install usb-uhci modprobe yenta_socket
pre-install ehci-hcd modprobe yenta_socket
alias ieee1394-controller ohci1394

I have not yet tested this
Comment 3 Philip Van Hoof 2003-10-15 08:18:53 EDT
Also note that I have the radeon with accel and dualhead working. This is also
explained on the wiki. It would be nice if RedHat could detect this laptop at
install-time and perform all patches as explained on the wiki automatically ;-). 
Comment 4 Philip Van Hoof 2003-10-20 16:04:48 EDT
It looks like #2 fixes a large amount of problems with this laptop. Both the
PCMCIA and USB subsystems are now working correctly, also hotswapping devices
with these busses appears to be working correctly. I suggest checking the wiki
frequently as people are submitting fixes for problems with this laptop at that
location.

After #2 has been applied, you can reenable the kudzu service and remove the
"nofirewire" option from the kernel-line in grub.conf. Rebooting will make stuff
like USB and PCMCIA work.
Comment 5 Philip Van Hoof 2003-10-22 08:40:56 EDT
It looks like these USB and PCMCIA fixes only work with a patched kernel. How to
patch and which patch (ACPI Support) is, again, described on the wiki.
Comment 6 Bugzilla owner 2004-09-30 11:41:28 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.