Bug 1029976 - jboss-servlet-3.0-api: FTBFS - unavailable maven-plugin-cobertura BR
jboss-servlet-3.0-api: FTBFS - unavailable maven-plugin-cobertura BR
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: jboss-servlet-3.0-api (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Ade Lee
Asha Akkiangady
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 11:03 EST by Stanislav Ochotnicky
Modified: 2014-06-18 04:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:29:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.40 KB, patch)
2013-11-13 11:28 EST, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Stanislav Ochotnicky 2013-11-13 11:03:25 EST
jboss-servlet-3.0-api fails to build from source due to maven-plugin-cobertura not being available[1]. Cobertura is mostly useful for upstream QA so I'd suggest removing dependency on cobertura from the package


[1] https://brewweb.devel.redhat.com/taskinfo?taskID=6572231
Comment 1 Mikolaj Izdebski 2013-11-13 11:28:25 EST
Created attachment 823524 [details]
Proposed patch
Comment 6 Jenny Galipeau 2014-01-29 17:09:40 EST
Verifying sanity only - developer library package that is a dependency for
dogtag which is a dependency of IPA

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)

# rpm -qi  jboss-servlet-3.0-api
Name        : jboss-servlet-3.0-api
Version     : 1.0.1
Release     : 9.el7
Architecture: noarch
Install Date: Wed 29 Jan 2014 04:54:02 PM EST
Group       : Development/Libraries
Size        : 107049
License     : CDDL
Signature   : RSA/SHA256, Sun 29 Dec 2013 03:52:36 PM EST, Key ID 938a80caf21541eb
Source RPM  : jboss-servlet-3.0-api-1.0.1-9.el7.src.rpm
Build Date  : Sat 28 Dec 2013 01:15:02 AM EST
Build Host  : x86-020.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://www.jboss.org
Summary     : Java Servlet 3.0 API
Description :
The Java Servlet 3.0 API classes.
Comment 7 Ludek Smid 2014-06-13 08:29:45 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.