Bug 1029990 - maven-plugin-tools: FTBFS - dependency with <scope>system</scope>
maven-plugin-tools: FTBFS - dependency with <scope>system</scope>
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: maven-plugin-tools (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mikolaj Izdebski
Jan Kepler
: Patch
: 1049544 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 11:24 EST by Stanislav Ochotnicky
Modified: 2014-06-18 03:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: 3.1-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:07:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.86 KB, patch)
2013-11-13 12:23 EST, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Stanislav Ochotnicky 2013-11-13 11:24:33 EST
maven-plugin-tools fails to build from source due to dependency on com.sun:tools with system scope[1]. It's impossible to know if given dependency will be resolvable so XMvn fails the build with system scoped dependencies. For example of a fix see [2]. 

[1] https://brewweb.devel.redhat.com/taskinfo?taskID=6572265
[2] https://lists.fedoraproject.org/pipermail/java-sig-commits/2013-September/013529.html
Comment 4 Mikolaj Izdebski 2013-11-13 12:23:12 EST
Created attachment 823590 [details]
Proposed patch
Comment 6 Mikolaj Izdebski 2013-11-14 05:30:22 EST
Fixed in maven-plugin-tools-3.1-16
Comment 9 Mikolaj Izdebski 2014-01-07 13:17:49 EST
*** Bug 1049544 has been marked as a duplicate of this bug. ***
Comment 10 Ludek Smid 2014-06-13 07:07:28 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.