Bug 1029998 - sisu: FTBFS - requires generator problem
sisu: FTBFS - requires generator problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sisu (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mikolaj Izdebski
Jan Kepler
: Patch
: 1049287 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 11:35 EST by Stanislav Ochotnicky
Modified: 2014-06-18 03:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.3.0-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:20:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.42 KB, patch)
2013-11-13 12:01 EST, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Stanislav Ochotnicky 2013-11-13 11:35:13 EST
sisu fails to build from source due to unresolvable dependencies for requires generator which fails the build to prevent incorrect package dependencies[1]. 

Snippet from build.log:
Exception: Following dependencies were not resolved and requires cannot be generated. Either remove the dependency from pom.xml or add proper packages to BuildRequires:
ch.qos.logback:logback-classic:::UNKNOWN
Following dependencies were not resolved and requires cannot be generated. Either remove the dependency from pom.xml or add proper packages to BuildRequires:
ch.qos.logback:logback-classic:::UNKNOWN


[1] https://brewweb.devel.redhat.com/taskinfo?taskID=6572332
Comment 1 Mikolaj Izdebski 2013-11-13 12:01:51 EST
Created attachment 823562 [details]
Proposed patch
Comment 4 Mikolaj Izdebski 2013-11-14 05:28:55 EST
Fixed in sisu-2.3.0-10
Comment 7 Stanislav Ochotnicky 2014-01-07 06:28:31 EST
*** Bug 1049287 has been marked as a duplicate of this bug. ***
Comment 8 Ludek Smid 2014-06-13 05:20:13 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.