Bug 1030065 - Black screen when starting SDDM
Black screen when starting SDDM
Status: CLOSED DUPLICATE of bug 1020921
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 15:55 EST by Juan Orti
Modified: 2013-11-19 09:18 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 09:18:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log (47.81 KB, text/x-log)
2013-11-13 15:55 EST, Juan Orti
no flags Details

  None (edit)
Description Juan Orti 2013-11-13 15:55:03 EST
Created attachment 823637 [details]
Xorg.log

Description of problem:
When starting SDDM, I only get a black screen. KDM works fine.

Version-Release number of selected component (if applicable):
sddm-0.2.0-0.16.20130914git50ca5b20.fc20.x86_64
sddm-themes-0.2.0-0.16.20130914git50ca5b20.fc20.noarch
kernel-devel-3.11.7-300.fc20.x86_64
xorg-x11-drv-modesetting-0.8.0-2.fc20.x86_64
xorg-x11-drv-ati-7.2.0-3.20131101git3b38701.fc20.x86_64
xorg-x11-drv-evdev-2.8.2-1.fc20.x86_64
xorg-x11-xinit-1.3.2-9.fc20.x86_64
xorg-x11-server-common-1.14.3-4.fc20.x86_64
xorg-x11-server-Xorg-1.14.3-4.fc20.x86_64
xorg-x11-xauth-1.0.7-4.fc20.x86_64

How reproducible:
In my computer, every time I try to start SDDM

Steps to Reproduce:
1. yum install sddm -y
2. systemctl enable sddm.service --force
3. systemctl stop kdm.service
4. systemctl start sddm.service

Actual results:
Black screen

Expected results:
Login screen

Additional info:
/proc/cmdline:
 BOOT_IMAGE=/vmlinuz-3.11.7-300.fc20.x86_64 root=UUID=5094ab56-5ea8-40c3-8e2c-d3a09a6fd537 ro rootflags=subvol=root rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=es rd.luks=0 vconsole.font=latarcyrheb-sun16 crashkernel=128M radeon.audio=1 rhgb quiet

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Barts XT [Radeon HD 6870] (prog-if 00 [VGA controller])
        Subsystem: Hightech Information System Ltd. Device 2010
        Flags: bus master, fast devsel, latency 0, IRQ 58
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at f7e20000 (64-bit, non-prefetchable) [size=128K]
        I/O ports at e000 [size=256]
        Expansion ROM at f7e00000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Legacy Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Capabilities: [150] Advanced Error Reporting
        Kernel driver in use: radeon
Comment 1 Martin Bříza 2013-11-14 06:36:33 EST
Hi,
Could you please provide the output of the dmesg, journalctl commands (it's sufficient if you provide them only for the releavant time period) and contents of your /var/log/Xorg.0.log if it is created in the process?
Thanks,
Martin
Comment 2 Juan Orti 2013-11-14 09:30:33 EST
I have discovered what's going on. I have my TV attached to the HDMI port and it was displaying the login screen at it.

In KDM I have my xranrd setup added to /etc/kde/kdm/Xsetup
Where can I do something silimar in sddm? /usr/share/apps/sddm/scripts/Xsession doesn't seem appropiate, it should be executed before writing the credentials.
Comment 3 Juan Orti 2013-11-14 09:35:21 EST
I have opened an issue upstream: https://github.com/sddm/sddm/issues/115
Comment 4 Martin Bříza 2013-11-19 09:18:46 EST
Thanks, this is the same issue as Bug 102092, I'm working on it

*** This bug has been marked as a duplicate of bug 1020921 ***

Note You need to log in before you can comment on or make changes to this bug.