Bug 1030123 - GRUB2 invalid /boot/grub2/grub.cfg
GRUB2 invalid /boot/grub2/grub.cfg
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 19:22 EST by Matt Woelfel
Modified: 2013-12-12 19:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-12 19:44:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system generated grub.cfg - fails to boot (4.44 KB, text/plain)
2013-11-13 19:22 EST, Matt Woelfel
no flags Details

  None (edit)
Description Matt Woelfel 2013-11-13 19:22:46 EST
Created attachment 823696 [details]
system generated grub.cfg - fails to boot

Description of problem:
GRUB2 has a menu entry bug where there's an erronious new line causing it to not boot.

Version-Release number of selected component (if applicable):
grub2-tools-2.00-25.fc20.x86_64
grubby-8.28-1.fc20.x86_64
grub2-2.00-25.fc20.x86_64
grub2-efi-2.00-25.fc20.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install Fedora 20 Beta (http://download.fedoraproject.org/pub/fedora/linux/releases/test/20-Beta/Live/x86_64/Fedora-Live-Desktop-x86_64-20-Beta-5.iso) using btrfs accross two disks with anaconda.
2. Reboot
3. Find error about /dev/sdb1 being an invalid grub command and drop into recovery console

Actual results:
Failure to boot

Expected results:
Successfully boot

Additional info:
I was able to edit the offending line at boot time by removing the new line as a workaround:
-  linux   /vmlinuz-3.11.7-300.fc20.x86_64 root=UUID=016ea47f-4530-46d7-b7d4-60f667ca399f LANG=en_US.UTF-8
/dev/sdb1 ro rootflags=subvol=root vconsole.font=latarcyrheb-sun16  vconsole.keymap=us rhgb quiet
+  linux   /vmlinuz-3.11.7-300.fc20.x86_64 root=UUID=016ea47f-4530-46d7-b7d4-60f667ca399f LANG=en_US.UTF-8 /dev/sdb1 ro rootflags=subvol=root vconsole.font=latarcyrheb-sun16  vconsole.keymap=us rhgb quiet

My system has two disks and I allocated 100% of both of them to btrfs using the anaconda installer.
Comment 1 Matt Woelfel 2013-12-12 19:44:37 EST
This seems to be fixed with the latest TC installer.

Note You need to log in before you can comment on or make changes to this bug.