This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 103014 - with kernel 2.4.21-1.1931.2.399 all 32 bit binaries dump core and die
with kernel 2.4.21-1.1931.2.399 all 32 bit binaries dump core and die
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-25 10:46 EDT by Albert Fluegel
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-25 10:48:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Albert Fluegel 2003-08-25 10:46:45 EDT
Description of problem:
upgraded kernel to 2.4.21-1.1931.2.399 on a opteron box.
Afterwards all 32 bit binaries dumped core. with
2.4.21-1.1931.2.389 there was no problem

Version-Release number of selected component (if applicable):
2.4.21-1.1931.2.399

How reproducible:
upgrade to 2.4.21-1.1931.2.399

Steps to Reproduce:
1. run any arbitrary 32 bit binary
2.
3.
    
Actual results:
core dump


Expected results:
program running normally


Additional info:
with 2.4.21-1.1931.2.389 there was no problem
glibc is glibc-2.3.2-74 (64 and 32 Bit versino)
Comment 1 Arjan van de Ven 2003-08-25 10:48:46 EDT
known bug; we fixed this late last week in version 405 and later; will appear in
RHN soon
Comment 2 Albert Fluegel 2003-08-25 11:15:00 EDT
Ok, sorry, the latest thing i get via up2date is 2.4.21-1.1931.2.393,
i was on the wrong system, which has a very similar name, but has
an opteron processor. So can i expect the problem is fixed when 399
is available ?
Comment 3 Rik van Riel 2003-08-25 11:18:20 EDT
This particular bug got fixed in kernel .409.
Comment 4 Arjan van de Ven 2003-08-25 11:19:06 EDT
405 or later, not 399.
393 is ok, 399 is broken, 405 is ok again
Comment 5 Arjan van de Ven 2003-08-25 11:20:17 EDT
eh ignore me; 409 is the one

Note You need to log in before you can comment on or make changes to this bug.