Bug 1030161 - ircd install fails to create ircd.pid file
ircd install fails to create ircd.pid file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ircd-ratbox (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 23:03 EST by Zamir SUN
Modified: 2014-03-12 08:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: ircd-ratbox-2.2.9-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-12 08:26:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zamir SUN 2013-11-13 23:03:11 EST
Description of problem:
ircd service cannot start properly after I installed ircd-ratbox.

Version-Release number of selected component (if applicable):

Name        : ircd-ratbox
Arch        : x86_64
Version     : 2.2.8
Release     : 11.fc19

[root@internal ircd]# cat /etc/redhat-release 
Fedora release 19 (Schrödinger’s Cat)
[root@internal ircd]# uname -r
3.9.5-301.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1.# yum install ircd-ratbox
2.# systemctl start ircd

Actual results:
Job for ircd.service failed. See 'systemctl status ircd.service' and 'journalctl -xn' for details.

# systemctl status ircd.service
ircd.service - Internet Relay Chat Program Server
   Loaded: loaded (/usr/lib/systemd/system/ircd.service; enabled)
   Active: failed (Result: timeout) since Thu 2013-11-14 10:56:26 CST; 22s ago
  Process: 7458 ExecStart=/usr/bin/ircd -pidfile /run/ircd.pid (code=exited, status=0/SUCCESS)


Nov 14 10:54:56 internal.sdauqihang.com systemd[1]: Starting Internet Relay Chat Program Server...
Nov 14 10:54:56 internal.sdauqihang.com ircd[7458]: ircd: version ircd-ratbox-2.2.8
Nov 14 10:54:56 internal.sdauqihang.com ircd[7458]: ircd: pid 7459
Nov 14 10:54:56 internal.sdauqihang.com ircd[7458]: ircd: running in background mode from /usr
Nov 14 10:54:56 internal.sdauqihang.com systemd[1]: PID file /run/ircd.pid not readable (yet?) after start.
Nov 14 10:56:26 internal.sdauqihang.com systemd[1]: ircd.service operation timed out. Terminating.
Nov 14 10:56:26 internal.sdauqihang.com systemd[1]: Failed to start Internet Relay Chat Program Server.
Nov 14 10:56:26 internal.sdauqihang.com systemd[1]: Unit ircd.service entered failed state.

Expected results:
ircd started without any error

Additional info:
Then I tried  as the following:
# touch /run/ircd.pid (the /run/ircd.pid DO NOT exists before this step.)
# chown ircd:ircd /run/ircd.pid 
# systemctl start ircd
And this time it works. So I think there maybe some steps missed in the installation scripts
Comment 1 Nils Philippsen 2014-02-21 08:31:08 EST
Same here, on Fedora 20. The issue is just a missing file in tmpfiles.d plus adapting the systemd unit file, I'll get on it.
Comment 2 Fedora Update System 2014-02-23 08:24:51 EST
ircd-ratbox-2.2.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ircd-ratbox-2.2.9-1.fc19
Comment 3 Fedora Update System 2014-02-23 08:25:13 EST
ircd-ratbox-2.2.9-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ircd-ratbox-2.2.9-1.fc20
Comment 4 lnie 2014-02-24 02:13:39 EST
ircd-ratbox-2.2.9-1.fc20 works
Comment 5 Zamir SUN 2014-02-24 03:55:10 EST
tested against Fedora 19 and it works now. Thanks.

# yum localinstall http://kojipkgs.fedoraproject.org//packages/ircd-ratbox/2.2.9/1.fc19/x86_64/ircd-ratbox-2.2.9-1.fc19.x86_64.rpm

#systemctl start ircd

# systemctl status ircd
ircd.service - Internet Relay Chat Program Server
   Loaded: loaded (/usr/lib/systemd/system/ircd.service; disabled)
   Active: active (running) since Mon 2014-02-24 16:51:10 CST; 2min 3s ago
<snip>

# ls -l /run/ircd* -R
/run/ircd-ratbox:
total 4
-rw-------. 1 ircd ircd 5 Feb 24 16:51 ircd.pid
Comment 6 Nils Philippsen 2014-02-24 06:21:46 EST
(In reply to Zamir SUN from comment #5)
> tested against Fedora 19 and it works now. Thanks.

Please leave karma then, that helps getting it pushed to stable in F-19.
Comment 7 Fedora Update System 2014-02-24 07:31:27 EST
Package ircd-ratbox-2.2.9-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ircd-ratbox-2.2.9-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3014/ircd-ratbox-2.2.9-1.fc19
then log in and leave karma (feedback).
Comment 8 Zamir SUN 2014-02-24 22:17:09 EST
(In reply to Nils Philippsen from comment #6)
> Please leave karma then, that helps getting it pushed to stable in F-19.
Sorry, I do not know this before.
Already replied on bodhi with karma and thanks for your info.
Comment 9 Fedora Update System 2014-03-12 08:26:28 EDT
ircd-ratbox-2.2.9-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2014-03-12 08:27:40 EDT
ircd-ratbox-2.2.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.