Bug 103031 - LTC4051-unable to display DBCS on AWT/Swing application
LTC4051-unable to display DBCS on AWT/Swing application
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: IBMJava2-JRE (Show other bugs)
3.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Karen Bennet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-25 13:55 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 09:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
test case (6.84 KB, application/octet-stream)
2003-08-25 13:59 EDT, IBM Bug Proxy
no flags Details
Performance testcase screen shot (7.19 KB, image/gif)
2003-08-25 14:01 EDT, IBM Bug Proxy
no flags Details
Swing Up test case screen shot (3.57 KB, image/gif)
2003-08-25 14:02 EDT, IBM Bug Proxy
no flags Details
RH 8 Performance Screen shot (18.57 KB, image/gif)
2003-08-25 14:03 EDT, IBM Bug Proxy
no flags Details
RH8 Swing (3.57 KB, image/gif)
2003-08-25 14:05 EDT, IBM Bug Proxy
no flags Details
proposed patch (23.01 KB, patch)
2003-08-26 06:58 EDT, Akira TAGOH
no flags Details | Diff
updated patch (23.36 KB, patch)
2003-08-29 05:09 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description IBM Bug Proxy 2003-08-25 13:55:33 EDT
The following has be reported by IBM LTC:  
unable to display DBCS on AWT/Swing application
Please fill in each of the sections below.

Hardware Environment: Pentium4 3GHz

Software Environment: RHEL 3.0 Beta1, WebSphereStudio WorkBench 2.1.1 GTK 
version with latest fix (Classic VM version J2RE 1.3.1 IBM build cxia32131-
20030711a
,J9 version IBM J9 build 20030702)


Steps to Reproduce:
1. this problem ocurrs on IBM JVM 1.3.1 standalone. To simplify the scenario, 
I'm explaing on IBM JVM 1.3.1 which is bundled in WSWB 2.1.1
2. export LD_ASSUME_KERNEL=2.2.5 on ja_JP.eucJP locale
3. run AWT application PerformanceExample.
4. run Swing application SwingUIjp. 

Actual Results:
at step 3, Japanese label of buttons are displayed as ?
at step 4, Japanese tex are displayed as square blank.

Expected Results:
Japanese text should be displayed

Additional Information:
There is no problem on RedHat 8.0.Created an attachment (id=1436)
test cases
I've just tried on Sun's JVM 1.4.1_05 pre release that I got from Hursley JIM 
site. It worked fine.Fuse-san - did this work OK on RH AS 2.1 ?Glen/Greg - this
is a Ship Issue against RHEL3 beta1, so please report this
to Red Hat as soon as possible.  Thanks.

Chinen-san - do you have any insight into this issue ?  Thanks.

Fuse-san - I have two questions for you:
1. Does this problem happen on RHAS 2.1 (without using LD_ASSUME_KERNEL) ?
2. Have you tried LD_ASSUME_KERNEL=2.4.1 and see what happens ?
Please let me know.  Thanks.
I don't have the RHAS 2.1 installed PC, I have to run regression for RHEL 3.0 
on my PC. I am unable to check on the RHAS 2.1 for a while.

invoking "java" itself gets segmentation fault on LD_ASSUME_KERNEL=2.4.1.Fuse-san,

I'll check on RHAS 2.1. Please wait a while.There is no problem on RHAS 2.1.

About RHEL 3.0 Beta 1, I'm making the environment now...I ran this scenario on
eclipse2.1 that is packaged with RHEL3.0 beta 1, and got 
the same corrupted characters with IBM JRE 1.3.1 SR5.  

Steps to recreate:
1. During setup and install of RHEL 3.0 beta 1, you need to make sure you check 
the box to install the programming option of Eclipse.
2. Download the IBM JRE 1.3.1 SR5 rpm and install it.  For example, I extracted 
in the opt directory.
3. Execute: export LD_ASSUME_KERNEL=2.2.5
4. Change to the /usr/bin/ directory
5. Run the eclipse executable pointing to the installed IBM JRE:
   ./eclipse -vm /opt/IBMJava2-131/jre/bin/java
6. Execute Fuse-san's testcases.

Created an attachment (id=1448)
Performance Testcase screenshot
Created an attachment (id=1449)
SwingUp Testcase screenshot
Created an attachment (id=1450)
RH80 Performance screenshot

This is a screenshot of the same Performance Example, but on RH8.0 with IBM JRE
131 SR5.Created an attachment (id=1451)
RH80 Swing screenshot

This is a screenshot of the same Swing example, but for RH8.0 with IBM JRE 131
SR5.Note that the tests conducted on RH8.0 were done with GTK 2.2.0
Comment 1 IBM Bug Proxy 2003-08-25 13:58:51 EDT
Please ignore attachments above this comment; incorrect reference.
Comment 2 IBM Bug Proxy 2003-08-25 13:59:41 EDT
Created attachment 93911 [details]
test case
Comment 3 IBM Bug Proxy 2003-08-25 14:01:09 EDT
Created attachment 93912 [details]
Performance testcase screen shot
Comment 4 IBM Bug Proxy 2003-08-25 14:02:13 EDT
Created attachment 93913 [details]
Swing Up test case screen shot
Comment 5 IBM Bug Proxy 2003-08-25 14:03:10 EDT
Created attachment 93914 [details]
RH 8 Performance Screen shot
Comment 6 IBM Bug Proxy 2003-08-25 14:05:00 EDT
Created attachment 93915 [details]
RH8 Swing
Comment 7 Bill Nottingham 2003-08-25 16:48:35 EDT
Does eclipse work when used with gcj, or with a different VM?
Comment 8 Akira TAGOH 2003-08-26 06:58:42 EDT
Created attachment 93930 [details]
proposed patch

Hmm, it looks like Java didn't deal with fonts.alias. fonts.dir is generated by
xfs initscript, and ttfonts-ja package just provides the alias name to keep the
generic family name. so I don't think fixing this issue in ttfonts-ja package
is possible.
Attached file will fixes the font issue on the demo applications at least. the
demo applications displayed the empty square when the wrong font are used. but
this test case just displayed ???. I'm not familiar with Java, though. I wonder
if ttfonts-ja causes this issue.
Comment 9 IBM Bug Proxy 2003-08-26 10:16:49 EDT
------ Additional Comments From chinen@jp.ibm.com  2003-25-08 20:37 -------
This defect seems to be caused thorough the file name of Japanese
TrueType fonts was changed.

Fuse-san and Mr. HWA TRUONG,
Could you show me the results of the following works?

1. Open the font.properties.ja file.
   It is in the IBMJava2-131/jre/lib/ directory.
2. Change the following lines.
  193,194c193,194
  < filename.gothic_medium_r=kochi-gothic.ttf
  < filename.minchol_medium_r=kochi-mincho.ttf
  ---
  > filename.gothic_medium_r=kochi-gothic-subst.ttf
  > filename.minchol_medium_r=kochi-mincho-subst.ttf

Thank you, 
Comment 10 Akira TAGOH 2003-08-27 02:44:54 EDT
I couldn't find such entry in font.properties.ja. I'm also using IBMJava2 1.3.1.
However your testcase works fine now after adding that entries to
font.properties.ja.  So I would close this bug as UPSTREAM.
Comment 11 Akira TAGOH 2003-08-29 05:09:29 EDT
Created attachment 94062 [details]
updated patch
Comment 12 Akira TAGOH 2003-08-29 05:10:50 EDT
At least we should be able to take care this patch for our package? reassigning
this to IBMJava2-JRE
Comment 13 IBM Bug Proxy 2004-01-30 08:34:44 EST
----- Additional Comments From chinen@jp.ibm.com  2004-01-30 05:59 -------
This bug doesn't occur on RHEL 3.0 public release.
So I'd like to close this bug.

Thanks all. 
Comment 15 Thomas Fitzsimmons 2004-09-20 09:48:11 EDT
Fixed in RHEL3.  Closing.

Note You need to log in before you can comment on or make changes to this bug.