Bug 1030541 - Hang if booted with multiple monitors connected
Hang if booted with multiple monitors connected
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 11:23 EST by Jaroslav Škarvada
Modified: 2015-06-29 08:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 08:55:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2013-11-14 11:23:34 EST
Description of problem:
I have two external monitors connected to the T500 dock (one through DVI, the other through DSUB). The internal intel graphics doesn't seem to be able to handle these two together with the LCD. Previously, for a very long time (IIRC since f14), if booted with the lid closed, the two external monitors were used. After some very recent update (which I am currently trying to trace down) this stopped working on f19 and still doesn't work on f20 (to which I upgraded the machine recently). The boot process now hangs in very near where it should start the GDM and the machine stops responding.

The only way how to use it now is to boot with the lid open outside the dock, then, after the X starts, return it to the dock and then manually disable the LCD and enable the two external monitors through the xrandr. Then it works correctly till next reboot. This is very annoying.

The only relevant things that I was able to dig from the logs is the following snippet from the Xorg.log:

[   115.078] (--) intel(0): Integrated Graphics Chipset: Intel(R) GM45
[   115.078] (EE) intel(0): [drm] failed to set drm interface version.
[   115.078] (EE) intel(0): Failed to become DRM master.
[   115.078] (II) UnloadModule: "intel"
[   115.078] (EE) Screen(s) found, but none have a usable configuration.
[   115.078] (EE).
Fatal server error:
[   115.078] (EE) no screens found(EE).
[   115.078] (EE).

There are no visible problems, back traces, in the /var/log/messages / journal

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.14.3-4.fc20.x86_64
xorg-x11-drivers-7.7-6.fc20.x86_64
xorg-x11-drv-intel-2.21.15-4.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot the machine inside dock with lid closed and connected two external monitors

Actual results:
The machine hangs

Expected results:
No hang

Additional info:
This worked correctly in the past and stopped working now after the system was updated. This may be not xorg bug, I am trying to trace the problem down. Booting with older kernel doesn't seems to resolve the problem.
Comment 1 Jaroslav Škarvada 2013-11-15 03:04:02 EST
It is Intel GMA 4500MHD.
Comment 2 Mikhail Zabaluev 2014-05-23 18:01:42 EDT
I have a very similar problem with just one screen of a ThinkPad T500.
With kernel 3.13.10-200.fc20.i686, the desktop boots fine, but with any kernel 3.14.x the boot hangs and the failure messages as provided comment #0 are found in the Xorg.log.
Comment 3 Fedora End Of Life 2015-05-29 05:45:44 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2015-06-29 08:55:11 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.