Bug 1030727 - [abrt] epiphany-3.10.1-1.fc20: ephy_sqlite_connection_table_exists: Process /usr/bin/epiphany was killed by signal 5 (SIGTRAP)
[abrt] epiphany-3.10.1-1.fc20: ephy_sqlite_connection_table_exists: Process /...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6e4f2f52e14d208ca7802e59101...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 21:59 EST by Juan M Garcia
Modified: 2014-09-19 06:00 EDT (History)
4 users (show)

See Also:
Fixed In Version: epiphany-3.10.3-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-19 06:00:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (48.26 KB, text/plain)
2013-11-14 21:59 EST, Juan M Garcia
no flags Details
File: cgroup (159 bytes, text/plain)
2013-11-14 22:00 EST, Juan M Garcia
no flags Details
File: core_backtrace (28.51 KB, text/plain)
2013-11-14 22:00 EST, Juan M Garcia
no flags Details
File: dso_list (12.55 KB, text/plain)
2013-11-14 22:00 EST, Juan M Garcia
no flags Details
File: environ (1.04 KB, text/plain)
2013-11-14 22:00 EST, Juan M Garcia
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-14 22:00 EST, Juan M Garcia
no flags Details
File: maps (60.84 KB, text/plain)
2013-11-14 22:00 EST, Juan M Garcia
no flags Details
File: open_fds (995 bytes, text/plain)
2013-11-14 22:00 EST, Juan M Garcia
no flags Details
File: proc_pid_status (926 bytes, text/plain)
2013-11-14 22:00 EST, Juan M Garcia
no flags Details
File: var_log_messages (551 bytes, text/plain)
2013-11-14 22:00 EST, Juan M Garcia
no flags Details

  None (edit)
Description Juan M Garcia 2013-11-14 21:59:51 EST
Description of problem:
This problem occurs really frequently when using the Bluefish text editor. When creating an html page in bluefish 2.2.4 it still uses epiphany-browser -n '%p'% as the command to launch the html page in epiphany. I changed this to reflect what is now used in Fedora 20 to launch epiphany -- epiphany -n '%p'&. Once this change is done in Bluefish you go to launch the preview in Epiphany and it will launch properly 3 or 4 times out of ten. It seems to occure more often when a epiphany window is already open. Repeatable? Yes as of 2013-11-14.

Version-Release number of selected component:
epiphany-3.10.1-1.fc20

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        epiphany -n file:///home/jgarcia/Documents/webpages/personal/index.html
crash_function: ephy_sqlite_connection_table_exists
executable:     /usr/bin/epiphany
kernel:         3.11.7-300.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (4 frames)
 #2 ephy_sqlite_connection_table_exists at ephy-sqlite-connection.c:176
 #3 ephy_history_service_initialize_hosts_table at ephy-history-service-hosts-table.c:34
 #4 run_history_service_thread at ephy-history-service.c:375
 #5 g_thread_proxy at gthread.c:798
Comment 1 Juan M Garcia 2013-11-14 21:59:59 EST
Created attachment 824251 [details]
File: backtrace
Comment 2 Juan M Garcia 2013-11-14 22:00:09 EST
Created attachment 824252 [details]
File: cgroup
Comment 3 Juan M Garcia 2013-11-14 22:00:13 EST
Created attachment 824253 [details]
File: core_backtrace
Comment 4 Juan M Garcia 2013-11-14 22:00:18 EST
Created attachment 824254 [details]
File: dso_list
Comment 5 Juan M Garcia 2013-11-14 22:00:23 EST
Created attachment 824255 [details]
File: environ
Comment 6 Juan M Garcia 2013-11-14 22:00:27 EST
Created attachment 824256 [details]
File: limits
Comment 7 Juan M Garcia 2013-11-14 22:00:30 EST
Created attachment 824257 [details]
File: maps
Comment 8 Juan M Garcia 2013-11-14 22:00:34 EST
Created attachment 824258 [details]
File: open_fds
Comment 9 Juan M Garcia 2013-11-14 22:00:37 EST
Created attachment 824259 [details]
File: proc_pid_status
Comment 10 Juan M Garcia 2013-11-14 22:00:41 EST
Created attachment 824260 [details]
File: var_log_messages
Comment 11 Michael Catanzaro 2014-01-03 14:12:18 EST
This happens about every other time I open Epiphany by clicking on a URL in another program.
Comment 12 Michael Catanzaro 2014-01-05 13:01:49 EST
Since it looks like there's no Fedora maintainer (gecko-bugs-nobody? Epiphany hasn't used gecko for years...) I've upstreamed this as https://bugzilla.gnome.org/show_bug.cgi?id=721589
Comment 13 Michael Catanzaro 2014-06-20 17:03:19 EDT
Another user experienced a similar problem:

Epiphany crashes almost 100% of the time whenever it is closed, and sometimes when opened twice in quick succession (e.g. when opening links in an email).

The problem is that two processes are trying to access the database at the same time. Can probably be fixed by backporting https://git.gnome.org/browse/epiphany/commit/src/ephy-search-provider.c?id=78e8d7f045396cd753a73f9106e19b3bb3fe5d57

reporter:       libreport-2.2.2
backtrace_rating: 4
cmdline:        epiphany https://raw.githubusercontent.com/gnome-design-team/gnome-mockups/master/system-settings/sharing/media-sharing.png
crash_function: ephy_sqlite_connection_table_exists
executable:     /usr/bin/epiphany
kernel:         3.14.7-200.fc20.x86_64
package:        epiphany-3.10.3-1.fc20
reason:         epiphany killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 14 Fedora Update System 2014-08-23 02:38:13 EDT
epiphany-3.10.3-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/epiphany-3.10.3-3.fc20
Comment 15 Fedora Update System 2014-08-23 22:57:29 EDT
Package epiphany-3.10.3-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing epiphany-3.10.3-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9735/epiphany-3.10.3-3.fc20
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2014-09-07 13:46:29 EDT
epiphany-3.10.3-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/epiphany-3.10.3-4.fc20
Comment 17 Fedora Update System 2014-09-09 18:15:15 EDT
Package epiphany-3.10.3-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing epiphany-3.10.3-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10412/epiphany-3.10.3-4.fc20
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2014-09-19 06:00:33 EDT
epiphany-3.10.3-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.