Bug 1030746 - Download of offline translation zip fails: Mapping id to msgctxt, but there is already a msgctxt for text flow id
Download of offline translation zip fails: Mapping id to msgctxt, but there i...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
development
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2
Assigned To: Sean Flanigan
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 23:08 EST by Sean Flanigan
Modified: 2014-02-18 01:48 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2-SNAPSHOT (20131127-0039)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-18 01:48:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (46.05 KB, text/plain)
2013-11-14 23:08 EST, Sean Flanigan
no flags Details

  None (edit)
Description Sean Flanigan 2013-11-14 23:08:03 EST
Created attachment 824288 [details]
server.log

Description of problem:
Download of offline translation zip fails with the log message: "Mapping id to msgctxt, but there is already a msgctxt for text flow id"

Version-Release number of selected component (if applicable):
Zanata version 3.2-SNAPSHOT (20131114-1743)

How reproducible:
Consistently

Steps to Reproduce:
1. Visit the documents page for a language in a project iteration (with project type = gettext) [Tested with authconfig 6.1.12-8 (Italian)]
2. Click Download All Files (zip), say Ye

Actual results:
In some cases, download progress bar never terminates.  Otherwise, it redirects to a generic error page.

Multiple server exceptions logged (see attachment for details):

java.util.concurrent.ExecutionException: java.lang.RuntimeException: Mapping id to msgctxt, but there is already a msgctxt for text flow id

java.lang.IllegalStateException: CDATA tags may not nest


Expected results:
Downloads a zip file containing zanata.xml and po files

Additional info:
Downloading the zip via the editor seems to be working.
Comment 1 Sean Flanigan 2013-11-15 01:02:18 EST
https://github.com/zanata/zanata-server/pull/273

This exception happens (can happen) when a PO project is treated as a non-PO project (using the 'offlinepo' format).  In this case, the project had its type set correctly, but the JSF page was using the wrong value for isPoProject.
Comment 2 Ding-Yi Chen 2013-11-26 22:52:14 EST
Bug confirm in Zanata version 3.1.3-SNAPSHOT (20131127-0023)
VERIFIED with Zanata version 3.2-SNAPSHOT (20131127-0039)

Note You need to log in before you can comment on or make changes to this bug.