Bug 1030764 - rhc domain update still works, even though it's deprecated
rhc domain update still works, even though it's deprecated
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 00:15 EST by brice
Modified: 2015-05-14 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 09:03:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brice 2013-11-15 00:15:24 EST
Description of problem:
Running <rhc domain update DOMAIN1 DOMAIN2> still renames my domain, even though a big yellow warning comes up claiming it's deprecated.


Version-Release number of selected component (if applicable):


How reproducible:
100% (of the three times I tried it)

Steps to Reproduce:
1. run <rhc domain update DOMAIN1 DOMAIN2> in the hopes of renaming a domain

2. Screen output is this:
[brice@localhost ~]$ rhc domain update bfallonf4 bfallonf3
Warning: This command is deprecated. Please use 'rhc domain-rename' instead.

Renaming domain 'bfallonf4' to 'bfallonf3' ... done

Actual results: Domain name is changed


Expected results: Domain shouldn't have been changed


Additional info: <rhc domain rename> still works. And when running <rhc domain --help> the help menu doesn't have <update> on it, meaning that it is indeed deprecated. The only reason I tried update was because I was going through the docs and they still said <update>... They have since been edited to say <rename>.
Comment 1 Jordan Liggitt 2013-11-15 09:03:12 EST
Deprecated means it still works, but will be removed at some point. As long as there's a warning, it's ok for it to still work.

Note You need to log in before you can comment on or make changes to this bug.