Bug 1030864 - Switching language from indic(like or_IN, te_IN) to language with typing booster enabled does not work.
Switching language from indic(like or_IN, te_IN) to language with typing boos...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster (Show other bugs)
20
All All
medium Severity high
: ---
: ---
Assigned To: anish
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 1040967
  Show dependency treegraph
 
Reported: 2013-11-15 05:05 EST by Bhushan Barve
Modified: 2015-04-12 19:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1040967 (view as bug list)
Environment:
Last Closed: 2013-12-12 08:47:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
input language switching issue. (68.96 KB, image/png)
2013-11-15 05:09 EST, Bhushan Barve
no flags Details
switching-typing-booster-from-oriya-to-english-works-for-me.ogv (264.46 KB, application/octet-stream)
2013-11-16 15:21 EST, Mike FABIAN
no flags Details

  None (edit)
Description Bhushan Barve 2013-11-15 05:05:52 EST
Description of problem:
When user tries to switch language from indic (like oriya, kannada, Telugu) to a language with typing booster enabled like en_US(Hunspell), Japanese (kana kanji), it does not work. The language in the panel at the top does change but does not get reflected in the editor.


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1.open gedit and select input language as oriya.
2.type some text with oriya and change language to en_US(Hunspell) or fr_FR(Hunspell) or japanese(kana kanji) and type some text.

Actual results:
observe that though language in the panel is changed to en_US(Hunspell), still the input is in oriya language in the editor.

Expected results:
user should be able to input in en_US(Hunspell) after switching.

Additional info:
Comment 1 Bhushan Barve 2013-11-15 05:09:50 EST
Created attachment 824406 [details]
input language switching issue.
Comment 2 Mike FABIAN 2013-11-16 15:21:58 EST
Created attachment 824968 [details]
switching-typing-booster-from-oriya-to-english-works-for-me.ogv

A video showing that switching typing booster from Oriya
to English works for me.

Tested in qemu on Fedora-20-TC1-x86_64-netinst.iso.

It also works fine for me on my main machine (real hardware)
which I updated to Fedora 20 Beta with fedup.
Comment 3 Mike FABIAN 2013-12-12 08:47:28 EST
I have no idea how to reproduce that, works just fine for me both on Fedora 20 and RHEL7 -> WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.