Bug 1030948 - [abrt] gnome-shell-3.8.4-14.el7: g_logv: Process /usr/bin/gnome-shell was killed by signal 5 (SIGTRAP)
[abrt] gnome-shell-3.8.4-14.el7: g_logv: Process /usr/bin/gnome-shell was kil...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.0
x86_64 Unspecified
high Severity medium
: rc
: 7.0
Assigned To: Florian Müllner
Desktop QE
abrt_hash:109dea52b3b964f500edabe90e3...
:
: 1065951 1069638 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 06:40 EST by Petr Sklenar
Modified: 2014-06-18 01:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (38.24 KB, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details
File: cgroup (171 bytes, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details
File: core_backtrace (34.52 KB, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details
File: dso_list (21.70 KB, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details
File: environ (1.73 KB, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details
File: maps (140.01 KB, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details
File: open_fds (69.73 KB, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details
File: proc_pid_status (1.07 KB, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details
File: var_log_messages (396 bytes, text/plain)
2013-11-15 06:40 EST, Petr Sklenar
no flags Details

  None (edit)
Description Petr Sklenar 2013-11-15 06:40:10 EST
Description of problem:


Version-Release number of selected component:
gnome-shell-3.8.4-14.el7

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell --mode=classic
crash_function: g_logv
executable:     /usr/bin/gnome-shell
kernel:         3.10.0-50.el7.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_logv at /lib64/libglib-2.0.so.0
 #1 g_log at /lib64/libglib-2.0.so.0
 #2 g_wakeup_new at /lib64/libglib-2.0.so.0
 #3 g_main_context_new at /lib64/libglib-2.0.so.0
 #4 g_dbus_connection_send_message_with_reply_sync at /lib64/libgio-2.0.so.0
 #5 g_dbus_connection_call_sync_internal at /lib64/libgio-2.0.so.0
 #6 g_dbus_connection_call_sync at /lib64/libgio-2.0.so.0
 #7 ffi_call_unix64 at /lib64/libffi.so.6
 #8 ffi_call at /lib64/libffi.so.6
 #9 ?? at /lib64/libgjs.so.0
Comment 1 Petr Sklenar 2013-11-15 06:40:13 EST
Created attachment 824490 [details]
File: backtrace
Comment 2 Petr Sklenar 2013-11-15 06:40:16 EST
Created attachment 824491 [details]
File: cgroup
Comment 3 Petr Sklenar 2013-11-15 06:40:19 EST
Created attachment 824492 [details]
File: core_backtrace
Comment 4 Petr Sklenar 2013-11-15 06:40:22 EST
Created attachment 824493 [details]
File: dso_list
Comment 5 Petr Sklenar 2013-11-15 06:40:24 EST
Created attachment 824494 [details]
File: environ
Comment 6 Petr Sklenar 2013-11-15 06:40:27 EST
Created attachment 824495 [details]
File: limits
Comment 7 Petr Sklenar 2013-11-15 06:40:30 EST
Created attachment 824496 [details]
File: maps
Comment 8 Petr Sklenar 2013-11-15 06:40:33 EST
Created attachment 824497 [details]
File: open_fds
Comment 9 Petr Sklenar 2013-11-15 06:40:36 EST
Created attachment 824498 [details]
File: proc_pid_status
Comment 10 Petr Sklenar 2013-11-15 06:40:39 EST
Created attachment 824499 [details]
File: var_log_messages
Comment 11 Petr Sklenar 2013-11-15 06:56:31 EST
what I did:
1, fresh installation of rhel7
2, after few minutes of running it got frozen
3, mouse works but I could click any icon in the gnome-shell
4, after +-5minutes ABRT wrote that catch a error and gnome starts working
Comment 13 Petr Sklenar 2013-11-15 07:51:08 EST
journalctl shows:

Nov 15 12:42:40 localhost.localdomain gnome-session[2323]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.
Nov 15 12:42:40 localhost.localdomain gnome-session[2323]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.
Nov 15 12:42:40 localhost.localdomain gnome-session[2323]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.
Nov 15 12:42:40 localhost.localdomain gnome-session[2323]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.
Nov 15 12:42:41 localhost.localdomain gnome-session[2323]: dconf-CRITICAL: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.
Comment 14 Petr Sklenar 2013-11-15 07:52:55 EST
ls -la /run/user/1000/dconf/user
-rw-------. 1 root root 2 Nov 15 12:38 /run/user/1000/dconf/user
Comment 15 Matthias Clasen 2013-12-11 13:40:54 EST
how did you create the user - in anaconda, in firstboot, or in gnome-initial-setup ?
Comment 16 Petr Sklenar 2013-12-12 04:28:36 EST
Hello,
user was created during installation, so in anaconda
Comment 17 Matthias Clasen 2014-01-07 22:22:58 EST
This is an fd leak in the search provider loading code.
It should be fixed by 

https://git.gnome.org/browse/gnome-shell/commit/?h=gnome-3-10&id=a3236997bee6eb8b487c9e1d72379751da6ba0ae
Comment 18 Florian Müllner 2014-02-07 10:41:05 EST
(In reply to Petr Sklenar from comment #11)
> what I did:
> 1, fresh installation of rhel7
> 2, after few minutes of running it got frozen
> 3, mouse works but I could click any icon in the gnome-shell
> 4, after +-5minutes ABRT wrote that catch a error and gnome starts working

Are you sure this is all you did? I have tried several times to reproduce this issue in a RHEL7 VM, without success so far.
Comment 19 Matthias Clasen 2014-02-25 13:22:23 EST
*** Bug 1069638 has been marked as a duplicate of this bug. ***
Comment 20 Florian Müllner 2014-03-06 13:35:56 EST
*** Bug 1065951 has been marked as a duplicate of this bug. ***
Comment 21 Florian Müllner 2014-03-06 13:54:10 EST
(In reply to Florian Müllner from comment #18)
> Are you sure this is all you did? I have tried several times to reproduce
> this issue in a RHEL7 VM, without success so far.

I still haven't been able to reproduce. However as I haven't found similar reports for Fedora 20, let's assume that the rewrite of the loading code that happened for 3.10 fixed the issue ...
Comment 23 Ludek Smid 2014-06-13 05:59:37 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.