This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1030978 - Maven bouncycastle dep problem
Maven bouncycastle dep problem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: truezip (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gerard Ryan
Fedora Extras Quality Assurance
:
Depends On: 1028371
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 07:41 EST by Aidan Delaney
Modified: 2013-11-24 18:42 EST (History)
4 users (show)

See Also:
Fixed In Version: truezip-7.6.6-11.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-24 18:42:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aidan Delaney 2013-11-15 07:41:59 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Aidan Delaney 2013-11-15 07:45:03 EST
I didn't mean to submit an empty bug ticket.

BZ issue #1028371 also applies to eclipse-m2e-core.  This means that it is not possible to install Eclipse Maven support.

# yum install eclipse-m2e-core 
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
Could not retrieve mirrorlist http://rpm.livna.org/mirrorlist-debug error was
14: HTTP Error 404 - Not Found
http://spot.fedorapeople.org/steam/fedora-20/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them. If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help).
--> Running transaction check
---> Package eclipse-m2e-core.noarch 0:1.4.0-7.fc20 will be installed
--> Processing Dependency: osgi(org.apache.maven.archetype.descriptor) for package: eclipse-m2e-core-1.4.0-7.fc20.noarch
--> Processing Dependency: osgi(org.apache.maven.archetype.catalog) for package: eclipse-m2e-core-1.4.0-7.fc20.noarch
--> Processing Dependency: maven-wagon-ahc for package: eclipse-m2e-core-1.4.0-7.fc20.noarch
--> Processing Dependency: maven-indexer for package: eclipse-m2e-core-1.4.0-7.fc20.noarch
--> Processing Dependency: maven-archetype-descriptor for package: eclipse-m2e-core-1.4.0-7.fc20.noarch
--> Processing Dependency: maven-archetype-common for package: eclipse-m2e-core-1.4.0-7.fc20.noarch
--> Processing Dependency: maven-archetype-catalog for package: eclipse-m2e-core-1.4.0-7.fc20.noarch
--> Processing Dependency: jchardet for package: eclipse-m2e-core-1.4.0-7.fc20.noarch
--> Processing Dependency: aether-transport-http for package: eclipse-m2e-core-1.4.0-7.fc20.noarch
--> Running transaction check
---> Package aether-transport-http.noarch 1:0.9.0-0.4.M3.fc20 will be installed
---> Package jchardet.noarch 0:1.1-8.fc20 will be installed
---> Package maven-archetype-catalog.noarch 0:2.2-3.fc20 will be installed
---> Package maven-archetype-common.noarch 0:2.2-3.fc20 will be installed
--> Processing Dependency: mvn(org.apache.maven.archetype:archetype-registry) = 2.2 for package: maven-archetype-common-2.2-3.fc20.noarch
---> Package maven-archetype-descriptor.noarch 0:2.2-3.fc20 will be installed
---> Package maven-indexer.noarch 0:5.1.1-4.fc20 will be installed
--> Processing Dependency: mvn(de.schlichtherle.truezip:truezip-file) for package: maven-indexer-5.1.1-4.fc20.noarch
--> Processing Dependency: mvn(de.schlichtherle.truezip:truezip-driver-zip) for package: maven-indexer-5.1.1-4.fc20.noarch
---> Package maven-wagon-ahc.noarch 0:1.2.1-9.fc20 will be installed
--> Running transaction check
---> Package maven-archetype-registry.noarch 0:2.2-3.fc20 will be installed
---> Package truezip-driver-zip.noarch 0:7.6.6-6.fc20 will be installed
--> Processing Dependency: mvn(de.schlichtherle.truezip:truezip-swing) = 7.6.6 for package: truezip-driver-zip-7.6.6-6.fc20.noarch
--> Processing Dependency: mvn(de.schlichtherle.truezip:truezip-kernel) = 7.6.6 for package: truezip-driver-zip-7.6.6-6.fc20.noarch
--> Processing Dependency: mvn(org.bouncycastle:bcprov-jdk16:1.46) for package: truezip-driver-zip-7.6.6-6.fc20.noarch
--> Processing Dependency: mvn(net.sourceforge.findbugs:annotations) for package: truezip-driver-zip-7.6.6-6.fc20.noarch
---> Package truezip-file.noarch 0:7.6.6-6.fc20 will be installed
--> Processing Dependency: mvn(de.schlichtherle.truezip:truezip-driver-file) = 7.6.6 for package: truezip-file-7.6.6-6.fc20.noarch
--> Running transaction check
---> Package findbugs.noarch 0:2.0.2-2.fc20 will be installed
--> Processing Dependency: jcip-annotations for package: findbugs-2.0.2-2.fc20.noarch
--> Processing Dependency: jFormatString for package: findbugs-2.0.2-2.fc20.noarch
--> Processing Dependency: findbugs-bcel for package: findbugs-2.0.2-2.fc20.noarch
---> Package truezip-driver-file.noarch 0:7.6.6-6.fc20 will be installed
---> Package truezip-driver-zip.noarch 0:7.6.6-6.fc20 will be installed
--> Processing Dependency: mvn(org.bouncycastle:bcprov-jdk16:1.46) for package: truezip-driver-zip-7.6.6-6.fc20.noarch
---> Package truezip-kernel.noarch 0:7.6.6-6.fc20 will be installed
---> Package truezip-swing.noarch 0:7.6.6-6.fc20 will be installed
--> Running transaction check
---> Package findbugs-bcel.noarch 0:5.3-0.1.20130910svn1521566.fc20 will be installed
---> Package jFormatString.noarch 0:0-0.11.20111215svn.fc20 will be installed
---> Package jcip-annotations.noarch 0:1-8.20060626.fc20 will be installed
---> Package truezip-driver-zip.noarch 0:7.6.6-6.fc20 will be installed
--> Processing Dependency: mvn(org.bouncycastle:bcprov-jdk16:1.46) for package: truezip-driver-zip-7.6.6-6.fc20.noarch
--> Finished Dependency Resolution
Error: Package: truezip-driver-zip-7.6.6-6.fc20.noarch (fedora)
           Requires: mvn(org.bouncycastle:bcprov-jdk16:1.46)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 2 Stanislav Ochotnicky 2013-11-15 07:56:03 EST
Reassigning to truezip (it needed a rebuild), there seems to be commit with a fix in git, but maybe update hasn't been created yet.
Comment 3 Alexander Kurtakov 2013-11-15 09:22:50 EST
Gerard, do you need any help with that ? I would like to fix it asap as f20 release is really close.
Comment 4 Aidan Delaney 2013-11-15 09:26:20 EST
A (horrible) fix for the symbol issues is to replace the symbols with fully qualified names.  Take the following %setup as an example of how to do this, though you may wish to do it with a proper patch.

After I do this though, I still end up with a packaging issue (below).  Note, I've been working on updating the SPEC to truezip 7.7.4.

%setup -q

find -type f -name *.zip -delete
find -type f -name *.jar -delete
find -type f -name *.class -delete

# Fix findbugs groupId (switch for new dep)                                                                                                                                     
#%pom_remove_dep com.google.code.findbugs:annotations                                                                                                                           

# Add jsr-305 as dependency for javax.annotation.concurrent                                                                                                                     
%pom_add_dep org.jsr-305:ri

%pom_disable_module %{name}-archetype

sed -i 's/DEFAULT_RCDSIZE/org.apache.commons.compress.archivers.tar.TarConstants.DEFAULT_RCDSIZE/g' truezip-driver/truezip-driver-tar/src/main/java/de/schlichtherle/truezip/fs\
/archive/tar/TarInputShop.java
sed -i 's/DEFAULT_BLKSIZE/org.apache.commons.compress.archivers.tar.TarConstants.DEFAULT_BLKSIZE/g' truezip-driver/truezip-driver-tar/src/main/java/de/schlichtherle/truezip/fs\
/archive/tar/TarInputShop.java

Packaging error:
Processing files: truezip-driver-parent-7.7.4-6.fc20.noarch
Traceback (most recent call last):
  File "/usr/lib/rpm/maven.req", line 169, in <module>
    builder = TagBuilder ()
  File "/usr/lib/rpm/maven.req", line 61, in __init__
    self.print_mvn_requires(path)
  File "/usr/lib/rpm/maven.req", line 148, in print_mvn_requires
    raise Exception(unknown_msg)
Exception: Following dependencies were not resolved and requires cannot be generated. Either remove the dependency from pom.xml or add proper packages to BuildRequires:
${project.groupId}:truezip-kernel:::UNKNOWN
${project.groupId}:truezip-kernel::tests:UNKNOWN

Following dependencies were not resolved and requires cannot be generated. Either remove the dependency from pom.xml or add proper packages to BuildRequires:
${project.groupId}:truezip-kernel:::UNKNOWN
${project.groupId}:truezip-kernel::tests:UNKNOWN
Terminated
Comment 5 Gerard Ryan 2013-11-15 13:37:58 EST
Thanks for the bug guys.

@Aidan, thanks for the fix info. if I can't improve on it, at least there'll be it! :) I think I know how to fix the additional errors that you're running into.

@Alexander: I should be able to get it done I think (just a delayed response since I'm at work all day and don't see messages here until I get home). If it's above my ability, I may pester you guys for assistance. :)
Comment 6 Fedora Update System 2013-11-15 19:16:07 EST
truezip-7.6.6-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/truezip-7.6.6-11.fc20
Comment 7 Fedora Update System 2013-11-17 02:01:27 EST
Package truezip-7.6.6-11.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing truezip-7.6.6-11.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21539/truezip-7.6.6-11.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-11-24 18:42:49 EST
truezip-7.6.6-11.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.