Bug 1031029 - Exit message: internal error unsupported configuration: Read/write, exclusive access, disks were present, but no leases specified
Exit message: internal error unsupported configuration: Read/write, exclusive...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 08:54 EST by Michael Everette
Modified: 2013-12-10 16:00 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 16:00:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 542773 None None None Never

  None (edit)
Comment 3 Jiri Denemark 2013-12-05 12:43:56 EST
It looks like the XML libvirt got from vdsm was wrong. Vdsm turns off automatic disk leases and so it is supposed to explicitly configure leases for all read/write disks used by a domain. The "Read/write, exclusive access, disks were present, but no leases specified" error is reported when there are read/write disks attached to a domain but there are no leases configured for them. Can you get the XML vdsm uses for the domain?
Comment 4 Jiri Denemark 2013-12-05 12:48:07 EST
I talked to Federico from RHEV storage team and apparently vdsm is configuring libvirt (in /etc/libvirt/qemu-sanlock.conf) so that

auto_disk_leases = 0
require_lease_for_disks = 0

However, the reported error message should only be reported if

auto_disk_leases = 0
require_lease_for_disks = 1

and there are no leases in domain XML.

That said, this looks like someone changed require_lease_for_disks to 1. Michael, can you check if that's the case?
Comment 5 Michael Everette 2013-12-05 12:52:24 EST
I will ask customer for it now.
Comment 6 Michael Everette 2013-12-10 09:47:37 EST
Customer has closed the case and not provided the info requested. He has updated to the latest iso and says he does not see same behaviour. We can close this bug. Thank you for the help.
Comment 7 Jiri Denemark 2013-12-10 16:00:43 EST
Thanks, I assume the problem was in wrong configuration of libvirt and whatever caused it is now gone.

Note You need to log in before you can comment on or make changes to this bug.