Bug 1031039 - [abrt] glusterfs-swift-proxy-3.3.1-15.fc18: gzip.py:94:__init__:IOError: [Errno 2] No such file or directory: '/etc/swift/object.ring.gz'
[abrt] glusterfs-swift-proxy-3.3.1-15.fc18: gzip.py:94:__init__:IOError: [Err...
Status: CLOSED NOTABUG
Product: Gluster-Swift
Classification: Community
Component: Proxy-server (Show other bugs)
1.8.0
i686 Unspecified
low Severity low
: ---
: ---
Assigned To: Luis Pabón
abrt_hash:8e68c1e1489fc1d333349f8266f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 09:08 EST by Alpha Master.Net
Modified: 2016-11-08 17:25 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 13:23:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.36 KB, text/plain)
2013-11-15 09:08 EST, Alpha Master.Net
no flags Details
File: dso_list (105 bytes, text/plain)
2013-11-15 09:08 EST, Alpha Master.Net
no flags Details
File: environ (193 bytes, text/plain)
2013-11-15 09:08 EST, Alpha Master.Net
no flags Details

  None (edit)
Description Alpha Master.Net 2013-11-15 09:08:45 EST
Description of problem:
Não estava fazendo nenhuma tarefa quando o alerta foi informado.

Version-Release number of selected component:
glusterfs-swift-proxy-3.3.1-15.fc18

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /usr/bin/swift-proxy-server /etc/swift/proxy-server.conf
executable:     /usr/bin/swift-proxy-server
kernel:         3.10.6-200.fc19.i686.PAE
runlevel:       N 5
type:           Python
uid:            160

Truncated backtrace:
gzip.py:94:__init__:IOError: [Errno 2] No such file or directory: '/etc/swift/object.ring.gz'

Traceback (most recent call last):
  File "/usr/bin/swift-proxy-server", line 22, in <module>
    run_wsgi(conf_file, 'proxy-server', default_port=8080, **options)
  File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 119, in run_wsgi
    init_request_processor(conf_file, app_section, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 246, in init_request_processor
    app = loadapp('config:%s' % conf_file, global_conf={'log_name': log_name})
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 247, in loadapp
    return loadobj(APP, uri, name=name, **kw)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 272, in loadobj
    return context.create()
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create
    return self.object_type.invoke(self)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 203, in invoke
    app = context.app_context.create()
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create
    return self.object_type.invoke(self)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 146, in invoke
    return fix_call(context.object, context.global_conf, **context.local_conf)
  File "/usr/lib/python2.7/site-packages/paste/deploy/util.py", line 56, in fix_call
    val = callable(*args, **kw)
  File "/usr/lib/python2.7/site-packages/swift/proxy/server.py", line 284, in app_factory
    return Application(conf)
  File "/usr/lib/python2.7/site-packages/swift/proxy/server.py", line 80, in __init__
    self.object_ring = object_ring or Ring(swift_dir, ring_name='object')
  File "/usr/lib/python2.7/site-packages/swift/common/ring/ring.py", line 141, in __init__
    self._reload(force=True)
  File "/usr/lib/python2.7/site-packages/swift/common/ring/ring.py", line 146, in _reload
    ring_data = RingData.load(self.serialized_path)
  File "/usr/lib/python2.7/site-packages/swift/common/ring/ring.py", line 63, in load
    gz_file = GzipFile(filename, 'rb')
  File "/usr/lib/python2.7/gzip.py", line 94, in __init__
    fileobj = self.myfileobj = __builtin__.open(filename, mode or 'rb')
IOError: [Errno 2] No such file or directory: '/etc/swift/object.ring.gz'

Local variables in innermost frame:
Comment 1 Alpha Master.Net 2013-11-15 09:08:50 EST
Created attachment 824559 [details]
File: backtrace
Comment 2 Alpha Master.Net 2013-11-15 09:08:54 EST
Created attachment 824560 [details]
File: dso_list
Comment 3 Alpha Master.Net 2013-11-15 09:08:59 EST
Created attachment 824561 [details]
File: environ
Comment 4 Luis Pabón 2013-11-15 13:23:42 EST
Hi I am not sure what version of swift or gluster you are using.  But it looks like to me that the environment is missing the ring files. 

Please read: https://github.com/gluster/gluster-swift/blob/master/doc/markdown/quick_start_guide.md#generate-ring-files
Comment 5 Luis Pabón 2013-11-15 13:33:29 EST
The previous comment assumed you are using gluster-swift, but it looks like to me that you are just using regular openstack swift.  OpenStack ring configuration can be found here:

http://docs.openstack.org/developer/swift/deployment_guide.html#preparing-the-ring

Note You need to log in before you can comment on or make changes to this bug.