Bug 1031046 - Wrong selinux context on /mnt and /mnt/lost+found
Wrong selinux context on /mnt and /mnt/lost+found
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ec2-images (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.7
Assigned To: Joey Boggs
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 09:24 EST by Ina Panova
Modified: 2017-05-09 14:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-09 14:30:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ina Panova 2013-11-15 09:24:04 EST
Description of problem:
On a fresh installed instance I perform restorecon command and it says that /mnt and /mnt/lost+found should have mnt_t instead of file_t label


restorecon reset /mnt context system_u:object_r:file_t:s0->system_u:object_r:mnt_t:s0
restorecon reset /mnt/lost+found context system_u:object_r:file_t:s0->system_u:object_r:mnt_t:s0

Version-Release number of selected component (if applicable):
RHEL-6.5_GA-x86_64-1-Access2 (ami-15c59f7c)

How reproducible:
always

Steps to Reproduce:
1. Launch instance
2. Add an ephemeral device
3. Wait until instance is created
4. Perform restorecon command on the instance

Actual results:
file_t label on /mnt and /mnt/lost+found

Expected results:
mnt_t label on /mnt and /mnt/lost+found
Comment 2 RHEL Product and Program Management 2013-11-18 10:18:07 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Joey Boggs 2017-05-09 14:30:39 EDT
I'm not able to reproduce this on 6.9. It also looks like the default labeling has been updated to reflect mnt_t and lost_found_t as well.

drwx------. root root system_u:object_r:lost_found_t:s0 lost+found
drwxr-xr-x. root root system_u:object_r:mnt_t:s0       mnt

If there are still issues please feel free to reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.