Bug 1031061 - error in radiusd when receives leap message
error in radiusd when receives leap message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: freeradius (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: John Dennis
Eduard Benes
: Regression
: 1031064 (view as bug list)
Depends On:
Blocks: 1000455 1035382
  Show dependency treegraph
 
Reported: 2013-11-15 09:40 EST by David Spurek
Modified: 2014-06-18 01:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: freeradius-3.0.0-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1035382 (view as bug list)
Environment:
Last Closed: 2014-06-13 07:48:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Spurek 2013-11-15 09:40:08 EST
Description of problem:
error in radiusd when receives leap message. Problem appears if radiusd receive leap message as second request. 


part of radiusd log:
...
(11) # Executing group from file /etc/raddb/sites-enabled/default
(11)   authenticate {
(11) eap : Expiring EAP session with state 0x9d6e13bf9f6d02e9
(11) eap : Finished EAP session with state 0x9d6e13bf9f6d02e9
(11) eap : Previous EAP request found for state 0x9d6e13bf9f6d02e9, released from the list
(11) eap : Peer sent LEAP (17)
(11) eap : EAP LEAP (17)
(11) eap : Calling eap_leap to process EAP data
(11) eap_leap : Stage 6
*** Error in `radiusd': malloc(): memory corruption: 0x00007fed3132dec0 ***
*** Error in `radiusd': malloc(): memory corruption: 0x00007fed3132dec0 ***


Version-Release number of selected component (if applicable):
freeradius-3.0.0-2.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 John Dennis 2013-11-26 17:04:01 EST
*** Bug 1031064 has been marked as a duplicate of this bug. ***
Comment 11 Ludek Smid 2014-06-13 07:48:33 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.