Bug 1031077 - Machine is not suspended if the lid is closed
Machine is not suspended if the lid is closed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 09:56 EST by Jaroslav Škarvada
Modified: 2013-11-18 06:48 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 06:48:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2013-11-15 09:56:51 EST
Description of problem:
Machine is not suspended if the lid is closed.

Version-Release number of selected component (if applicable):
systemd-208-4.fc20.i686

How reproducible:
Always

Steps to Reproduce:
1. Close lid

Actual results:
Suspend

Expected results:
No suspend

Additional info:
From the docs, the suspend should be the default action. I also tried to edit the /etc/systemd/logind.conf and uncommented the HandleLidSwitch=suspend, but it didn't help. The lid switch seems to be detected, because desktop locked the screen. I tried xfce4 and gnome shell on two different machines and it seems to be the same.
Comment 1 Jaroslav Škarvada 2013-11-15 09:57:52 EST
(In reply to Jaroslav Škarvada from comment #0)
> Actual results:
> Suspend
> 
> Expected results:
> No suspend
> 
Of course vice versa:

Actual results:
No suspend

Expected results:
Suspend
Comment 2 Michal Schmidt 2013-11-15 10:41:53 EST
Works for me both with Gnome Shell and with a non-graphical system (booted into multi-user.target). Could you test the latter too?

Please also paste the output of the command "systemd-inhibit".
Comment 3 Flóki Pálsson 2013-11-15 18:50:37 EST
It works fore me with Fedora-Live-Desktop-i686-20-TC1.iso on Thinkpad T60.
See Bug 1029215
Comment 4 Jaroslav Škarvada 2013-11-18 06:48:59 EST
I updated to latest updates-testing and I can confirm it works on both of my machines in console.

In desktop, it needs to be explicitly enabled in power manager. Its settings take precedence, which I think is correct.

Note You need to log in before you can comment on or make changes to this bug.