Bug 1031109 - [vdsm] vdsm.spec restorecon verbosity
[vdsm] vdsm.spec restorecon verbosity
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Mooli Tayer
Jiri Belka
infra
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 10:57 EST by Jiri Belka
Modified: 2016-02-10 14:27 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A previous commit contained the 'verbose' option for the restorecon command for /var/log/core, which overloaded the console with messages during installation. This fix removes the verbose option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:21:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21888 None None None Never
oVirt gerrit 22021 None None None Never

  None (edit)
Description Jiri Belka 2013-11-15 10:57:28 EST
Description of problem:

BZ1005031 introduced a hack but it contains '-v' for restorecon which spams consoel during installation.

http://gerrit.ovirt.org/#/c/20705/7/vdsm.spec.in,unified

Preparing...                ########################################### [100%]
   1:vdsm-python            ########################################### [ 20%]
   2:vdsm-xmlrpc            ########################################### [ 40%]
   3:vdsm                   ########################################### [ 60%]
/sbin/restorecon reset /var/log/core context system_u:object_r:var_log_t:s0->system_u:object_r:virt_cache_t:s0
/sbin/restorecon reset /var/log/core/core.18314.1384435632.dump-20131114.xz context system_u:object_r:var_log_t:s0:c348,c660->system_u:object_r:virt_cache_t:s0
:c348,c660
/sbin/restorecon reset /var/log/core/core.18314.1384435632.dump.1.xz context system_u:object_r:var_log_t:s0:c348,c660->system_u:object_r:virt_cache_t:s0:c348,c
660
/sbin/restorecon reset /var/log/core/core.19721.1384437262.dump-20131114.xz context system_u:object_r:var_log_t:s0:c130,c865->system_u:object_r:virt_cache_t:s0
:c130,c865
/sbin/restorecon reset /var/log/core/core.19721.1384437262.dump.1.xz context system_u:object_r:var_log_t:s0:c130,c865->system_u:object_r:virt_cache_t:s0:c130,c
865
   4:vdsm-reg               ########################################### [ 80%]
   5:vdsm-cli               ########################################### [100%]


Version-Release number of selected component (if applicable):
is23

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
spam

Expected results:
not spam

Additional info:
this is probably even more relevant if it is going to be backported
Comment 1 Mooli Tayer 2013-12-08 19:11:41 EST
fixed in commit 80a6a1 on master
and 6ffd5d on 3.3
Comment 3 Jiri Belka 2013-12-11 05:04:10 EST
ok, vdsm-4.13.2-0.2.rc.el6ev.x86_64.rpm
Comment 4 errata-xmlrpc 2014-01-21 11:21:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.