Bug 1031155 - Download Process PDF - Error
Download Process PDF - Error
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER6
: 6.0.0
Assigned To: Ryan Zhang
Marek Baluch
:
Depends On:
Blocks: 976473
  Show dependency treegraph
 
Reported: 2013-11-15 13:08 EST by Jose Villasis
Modified: 2014-08-06 16:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 13528, User Guide-6-Beta-1 Build Date: 28-10-2013 14:07:45 Topic ID: 14331-489755 [Latest]
Last Closed: 2014-08-06 16:11:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Villasis 2013-11-15 13:08:08 EST
Title: Exporting a Process


Describe the issue:

When trying to export the process documentation to PDF shows the following page:


JBWEB000065: HTTP Status 500 -

JBWEB000309: type JBWEB000066: Exception report

JBWEB000068: message

JBWEB000069: description JBWEB000145: The server encountered an internal error that prevented it from fulfilling this request.

JBWEB000070: exception

javax.enterprise.event.ObserverException
	sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	java.lang.reflect.Constructor.newInstance(Constructor.java:513)
	java.lang.Class.newInstance0(Class.java:355)
	java.lang.Class.newInstance(Class.java:308)
	org.jboss.weld.util.reflection.SecureReflections$16.work(SecureReflections.java:344)
	org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:52)
	org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInstantiation(SecureReflectionAccess.java:173)
	org.jboss.weld.util.reflection.SecureReflections.newInstance(SecureReflections.java:341)
	org.jboss.weld.injection.Exceptions.rethrowException(Exceptions.java:33)
	org.jboss.weld.injection.Exceptions.rethrowException(Exceptions.java:73)
	org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:162)
	org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:245)
	org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:233)
	org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:213)
	org.jboss.weld.event.ObserverNotifier.notifyObserver(ObserverNotifier.java:117)
	org.jboss.weld.event.TransactionalObserverNotifier.notifyObserver(TransactionalObserverNotifier.java:44)
	org.jboss.weld.event.ObserverNotifier.notifyObservers(ObserverNotifier.java:85)
	org.jboss.weld.event.ObserverNotifier.fireEvent(ObserverNotifier.java:75)
	org.jboss.weld.event.ObserverNotifier.fireEvent(ObserverNotifier.java:70)
	org.jboss.weld.manager.BeanManagerImpl.fireEvent(BeanManagerImpl.java:562)
	org.jboss.solder.servlet.exception.CatchExceptionFilter.doFilter(CatchExceptionFilter.java:74)
	org.jboss.solder.servlet.event.ServletEventBridgeFilter.doFilter(ServletEventBridgeFilter.java:74)
	org.jbpm.designer.web.filter.impl.PluggableFilter.doFilter(PluggableFilter.java:70)
JBWEB000071: root cause

javax.servlet.ServletException: JBWEB000248: Servlet execution threw an exception
	org.jboss.solder.servlet.exception.CatchExceptionFilter.doFilter(CatchExceptionFilter.java:65)
	org.jboss.solder.servlet.event.ServletEventBridgeFilter.doFilter(ServletEventBridgeFilter.java:74)
	org.jbpm.designer.web.filter.impl.PluggableFilter.doFilter(PluggableFilter.java:70)
JBWEB000071: root cause

java.lang.NoSuchMethodError: org.apache.avalon.framework.configuration.DefaultConfiguration.<init>(Ljava/lang/String;)V
	org.apache.fop.svg.PDFTranscoder.transcode(PDFTranscoder.java:172)
	org.apache.batik.transcoder.XMLAbstractTranscoder.transcode(Unknown Source)
	org.apache.batik.transcoder.SVGAbstractTranscoder.transcode(Unknown Source)
	org.jbpm.designer.web.server.TransformerServlet.storeInRepository(TransformerServlet.java:451)
	org.jbpm.designer.web.server.TransformerServlet.doPost(TransformerServlet.java:144)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
	org.jboss.solder.servlet.exception.CatchExceptionFilter.doFilter(CatchExceptionFilter.java:65)
	org.jboss.solder.servlet.event.ServletEventBridgeFilter.doFilter(ServletEventBridgeFilter.java:74)
	org.jbpm.designer.web.filter.impl.PluggableFilter.doFilter(PluggableFilter.java:70)
JBWEB000072: note JBWEB000073: The full stack trace of the root cause is available in the JBoss Web/7.2.2.Final-redhat-1 logs.

JBoss Web/7.2.2.Final-redhat-1
Comment 2 Tihomir Surdilovic 2013-11-20 10:48:31 EST
This is a side effect of bug https://bugzilla.redhat.com/show_bug.cgi?id=996210. Designer specifically uses batik 1.6 which has to be used in order for png and pdf exports to work.
Comment 5 Tihomir Surdilovic 2013-11-26 13:13:21 EST
Please let me know what to do about this issue. Designer PNG/PDF generation requires batik 1.6 and fop 1.0 libraries. If those are not present these types of issues will occur. Let me know what I can do here.
Comment 6 Kris Verlaenen 2013-11-26 13:59:20 EST
I verified that PDF generation seems to work as expected in 6.0.0.Final, so please retest with ER5.
Comment 7 Marek Baluch 2013-11-26 14:14:21 EST
Moving to ON_QA as this will be retested with ER5.
Comment 8 Marek Baluch 2013-11-27 05:19:39 EST
Kris this does not work on BPMS 6.0.0.ER5.

I'm getting the same exception (also for 'share PDF')
Comment 9 Kris Verlaenen 2013-11-27 14:22:00 EST
This seems to be caused by a difference in version of the avalon-framework jar.  In jBPM 6.0.0.Final in the community, we are depending on v4.1.4, however BPMS packages v4.1.3.

@Ryan, could you please run dependency:tree on kie-wb to check why a different version in included for the product?
Comment 10 Ryan Zhang 2013-11-27 19:49:44 EST
Yes.
EAP 6.1.1 defines avalon-framework 4.1.3. (See EAP bom in [1])
When doing productization,we will aligin with the dependency with EAP 6.1.1.


[1]: http://download.lab.bos.redhat.com/brewroot/repos/jb-ip-6-build/latest/maven/org/jboss/component/management/jboss-component-version-master/6.1.1.Final-redhat-61/jboss-component-version-master-6.1.1.Final-redhat-61.pom

(In reply to Kris Verlaenen from comment #9)
> This seems to be caused by a difference in version of the avalon-framework
> jar.  In jBPM 6.0.0.Final in the community, we are depending on v4.1.4,
> however BPMS packages v4.1.3.
> 
> @Ryan, could you please run dependency:tree on kie-wb to check why a
> different version in included for the product?
Comment 11 Kris Verlaenen 2013-11-29 09:58:04 EST
Ryan, I couldn't find avalon-framework in the link you specified, am I missing something?

Note that, because we override the default version of batik in BPMS (as discussed on the PM calls), this also includes apache fop and avalon-framework versions (which it depends on).
Comment 12 Ryan Zhang 2013-12-05 23:47:32 EST
It is there, please search:
<version.avalon-framework>4.1.3</version.avalon-framework>

I can override the avalon-framework version to 4.1.4 in IPBOM as requested.
If the root cause is only the avalon-frame work version, please assign it to me, I will fix it in ER6.
(In reply to Kris Verlaenen from comment #11)
> Ryan, I couldn't find avalon-framework in the link you specified, am I
> missing something?
> 
> Note that, because we override the default version of batik in BPMS (as
> discussed on the PM calls), this also includes apache fop and
> avalon-framework versions (which it depends on).
Comment 13 Marek Baluch 2013-12-21 04:42:13 EST
Setting to ON_QA. This fix should have made it into the product.
Comment 14 Marek Baluch 2013-12-21 04:43:11 EST
Verified on ER6.

PDF download works.

Note You need to log in before you can comment on or make changes to this bug.