Bug 1031166 - Can't mount a GlusterFS NFS export if you include a directory in the source field on Tru64 (V4.0 1229 alpha) mount
Can't mount a GlusterFS NFS export if you include a directory in the source f...
Status: CLOSED DUPLICATE of bug 1118311
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.4.1
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ric Wheeler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 13:44 EST by Derek Schrock
Modified: 2014-08-18 09:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-18 09:27:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Schrock 2013-11-15 13:44:26 EST
Description of problem:

Can't mount a GlusterFS NFS export if you include a directory in the source field on Tru64 (V4.0 1229 alpha) mount.  Get the repeating error:

Bad MNT RPC: gluster04.switch.com:/resd/csxmig: RPC: Remote system error


How reproducible:
Turn on nfs.mount-udp
Try to mount with a GlusterFS NFS export with a directory in the source field

Steps to Reproduce:
1. Mount with directory in your source field
# mount -t nfs -o vers=3,tcp gluster04.switch.com:/resd/csxmig /tmp/foo
Bad MNT RPC: gluster04.switch.com:/resd/csxmig: RPC: Remote system error
Bad MNT RPC: gluster04.switch.com:/resd/csxmig: RPC: Remote system error
....
^C
#

Actual results:
Repeating error
Bad MNT RPC: gluster04.switch.com:/resd/csxmig: RPC: Remote system error

Expected results:
Mount the export

Additional info:
This might be related to Bug 1031164
Comment 1 Derek Schrock 2013-11-15 16:43:31 EST
Additional info:

The Tru64 NFS client works fine with a Native Linux NFS (kernel) server.
Comment 3 Niels de Vos 2014-08-18 09:27:16 EDT
This seems to be the same issue as bug 1118311, please follow progress there.

*** This bug has been marked as a duplicate of bug 1118311 ***

Note You need to log in before you can comment on or make changes to this bug.