Bug 1031261 - PartitionException: Unable to satisfy all constraints on the partition.
PartitionException: Unable to satisfy all constraints on the partition.
Status: CLOSED DUPLICATE of bug 1168380
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:47af1c11dc2555499cc5a26f9df...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 04:29 EST by dipu
Modified: 2014-12-09 09:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-09 09:13:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (669.25 KB, text/plain)
2013-11-16 04:29 EST, dipu
no flags Details
File: anaconda.log (9.25 KB, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details
File: environ (404 bytes, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details
File: lsblk_output (2.67 KB, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details
File: nmcli_dev_list (4.38 KB, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details
File: os_info (291 bytes, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details
File: program.log (44.81 KB, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details
File: storage.log (138.40 KB, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details
File: syslog (88.43 KB, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details
File: ifcfg.log (646 bytes, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details
File: packaging.log (338.38 KB, text/plain)
2013-11-16 04:30 EST, dipu
no flags Details

  None (edit)
Description dipu 2013-11-16 04:29:39 EST
Description of problem:
I was reinstalling the system. Selected the option to shrink free space from a partition

Version-Release number of selected component:
anaconda-20.25.6-1

The following was filed automatically by anaconda:
anaconda 20.25.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/parted/disk.py", line 246, in addPartition
    constraint.getPedConstraint())
  File "/usr/lib/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 1939, in growPartitions
    constraint=constraint)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 788, in doPartitioning
    growPartitions(disks, partitions, free, size_sets=storage.size_sets)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 320, in doAutoPartition
    doPartitioning(storage)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 263, in execute
    doAutoPartition(storage, ksdata)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1740, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 429, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
PartitionException: Unable to satisfy all constraints on the partition.

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20i386 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta

Potential duplicate: bug 892093
Comment 1 dipu 2013-11-16 04:29:58 EST
Created attachment 824843 [details]
File: anaconda-tb
Comment 2 dipu 2013-11-16 04:30:02 EST
Created attachment 824844 [details]
File: anaconda.log
Comment 3 dipu 2013-11-16 04:30:06 EST
Created attachment 824845 [details]
File: environ
Comment 4 dipu 2013-11-16 04:30:11 EST
Created attachment 824846 [details]
File: lsblk_output
Comment 5 dipu 2013-11-16 04:30:15 EST
Created attachment 824847 [details]
File: nmcli_dev_list
Comment 6 dipu 2013-11-16 04:30:20 EST
Created attachment 824848 [details]
File: os_info
Comment 7 dipu 2013-11-16 04:30:25 EST
Created attachment 824849 [details]
File: program.log
Comment 8 dipu 2013-11-16 04:30:30 EST
Created attachment 824850 [details]
File: storage.log
Comment 9 dipu 2013-11-16 04:30:36 EST
Created attachment 824851 [details]
File: syslog
Comment 10 dipu 2013-11-16 04:30:40 EST
Created attachment 824852 [details]
File: ifcfg.log
Comment 11 dipu 2013-11-16 04:30:50 EST
Created attachment 824853 [details]
File: packaging.log
Comment 13 Dilip 2014-01-28 23:21:53 EST
cannot install fedora on sda9 partition

sda1 windows
sda2 boot
sda3 extended
sda5 swap
sda6-8 linux OSes around 15GB each
sda9-sda11 free partitons of ~15GB each
sda12 linux partition - rest of hdd space

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 quiet
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
package:        anaconda-20.25.15-1
product:        Fedora
reason:         PartitionException: Unable to satisfy all constraints on the partition.
release:        Cannot get release name.
version:        20
Comment 14 David Shea 2014-12-09 09:13:34 EST

*** This bug has been marked as a duplicate of bug 1168380 ***

Note You need to log in before you can comment on or make changes to this bug.