Bug 1031295 - sddm no longer includes "custom" login session
sddm no longer includes "custom" login session
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 09:55 EST by Chuck Murnane
Modified: 2013-11-16 10:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-16 10:04:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Murnane 2013-11-16 09:55:10 EST
Description of problem:
sddm-0.2.0-0.4.20130821gite707e229.fc19 allows selection of "custom" as a login session. This option was removed in sddm-0.2.0-0.16.20130914git50ca5b20.fc19

Version-Release number of selected component (if applicable):
sddm-0.2.0-0.16.20130914git50ca5b20.fc19

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
custom is no longer an option in the list of login session choices.

Expected results:
"custom" allows users to choose a login session "once for all", without requiring selection of a login session from a menu list of them.

Additional info:

sddm does not appear to include code to remember the individual users' last login session. This means that each user must select the login session at each login. Use of the custom login session allows the users to choose a login session without further action at each login. While I view use of custom as a work-around for sddm's failure to track individual users' login session choices, it is useful in keeping my wife happy with the computer system. The current sddm code simply made a comment of the code to add the custom entry to the list of login session choices. All the code to process the users' .xsession files remains.

Would you care to discuss your plans for login session choice developments? Do you have a method for per-user login session "one-time" setup in mind as a future target of sddm development?

Thank you.
Comment 1 Kevin Kofler 2013-11-16 10:04:57 EST
"Custom" was removed because it was buggy and because SDDM insisted on defaulting to it instead of something sane (a normal KDE session), see bug #1004902.

> sddm does not appear to include code to remember the individual users' last
> login session.

It does, it is just not enabled by default. (IMHO, it should be.)

Note You need to log in before you can comment on or make changes to this bug.