Bug 1031304 - "hostonly=yes" breaks resume from disk; dracut ignores "hostonly" setting in dracut.conf
"hostonly=yes" breaks resume from disk; dracut ignores "hostonly" setting in ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
20
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 11:53 EST by d141221
Modified: 2014-01-22 05:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-22 05:56:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fstab (502 bytes, text/plain)
2013-11-18 07:04 EST, d141221
no flags Details
dracut-debug.log (6.52 MB, text/plain)
2013-11-18 07:09 EST, d141221
no flags Details

  None (edit)
Description d141221 2013-11-16 11:53:52 EST
Description of problem:
Inintrds created by dracut won't resume from disk if they're host-only. Setting "hostonly=no" in /etc/dracut.conf has no effect; only the command-line option works. It's possible to make the system resume from disk if the device is added manually to a .conf snippet in /etc/dracut.conf.d.

Version-Release number of selected component (if applicable):
dracut-034-19.git20131021.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run 'systemctl hibernate' and wait until it saves the image to disk
2. Power on the computer

Actual results:
Hibernation image is completely ignored on boot.

Expected results:
The system should at least check if there's a hibernation image on the swap device and resume from it, if applicable.

Additional info:
* Workaround 1: dracut -f --no-hostonly --regenerate-all
* Workaround 2: add the swap partition manually to a .conf snippet in /etc/dracut.conf.d (add_device+=" /dev/<swap partition> ")
* Partition table is GPT (not sure if this matters)
Comment 1 Harald Hoyer 2013-11-18 06:57:00 EST
please attach your /etc/fstab

please attach the output of:

# dracut -f --debug
Comment 2 d141221 2013-11-18 07:04:25 EST
Created attachment 825569 [details]
fstab
Comment 3 d141221 2013-11-18 07:09:35 EST
Created attachment 825570 [details]
dracut-debug.log
Comment 4 d141221 2013-11-18 07:10:34 EST
The swap entry is commented out because systemd tries to enable it twice, slowing down boot by 20 seconds or so.
Comment 5 Harald Hoyer 2013-11-19 07:04:54 EST
(In reply to enthymeme from comment #4)
> The swap entry is commented out because systemd tries to enable it twice,
> slowing down boot by 20 seconds or so.

Well, dracut wants that entry. No swap -> no resume.
Comment 6 d141221 2013-11-19 09:53:42 EST
So I have to choose between snail-slow boot and working resume from disk? I wouldn't even care about boot times if hibernation wasn't half-broken.

Note You need to log in before you can comment on or make changes to this bug.