Bug 1031322 - [abrt] dnf-0.4.7-1.fc20: comps.py:29:<module>:ImportError: No module named libcomps
[abrt] dnf-0.4.7-1.fc20: comps.py:29:<module>:ImportError: No module named li...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:1a1a7fbc60f773dddcca48b9da7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 15:24 EST by diego brizuela
Modified: 2014-06-23 21:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-23 21:33:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (6.73 KB, text/plain)
2013-11-16 15:24 EST, diego brizuela
no flags Details
File: environ (72 bytes, text/plain)
2013-11-16 15:25 EST, diego brizuela
no flags Details

  None (edit)
Description diego brizuela 2013-11-16 15:24:50 EST
Description of problem:
suddenly, on startup

Version-Release number of selected component:
dnf-0.4.7-1.fc20

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/dnf -v makecache timer
executable:     /usr/bin/dnf
kernel:         3.11.8-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
#1 <module> in /usr/lib/python2.7/site-packages/dnf/comps.py:29
#2 <module> in /usr/lib/python2.7/site-packages/dnf/base.py:39
#3 <module> in /usr/lib/python2.7/site-packages/dnf/__init__.py:24
#4 <module> in /usr/bin/dnf:34
Comment 1 diego brizuela 2013-11-16 15:24:59 EST
Created attachment 824970 [details]
File: backtrace
Comment 2 diego brizuela 2013-11-16 15:25:02 EST
Created attachment 824971 [details]
File: environ
Comment 3 Ales Kozumplik 2013-11-18 02:18:38 EST
Hello, how often does this happen, can you reproduce? what does 'rpm -q libcomps' output?

Same core problem as bug 1029892.
Comment 4 Ales Kozumplik 2013-11-18 03:56:20 EST
(if this happens on a proper installation where all the requirements are present, the theory I would incline to is that systemd activates the timer before all DNF components are in place during an rpm transaction and that (through OnBootSec=10min) immediately fires up 'dnf makecache' which is still missing some parts)
Comment 5 Ales Kozumplik 2013-11-18 12:36:45 EST
(Turns out systemd does not activate the timer, it merely enables it.)
Comment 6 Ales Kozumplik 2013-11-18 12:39:49 EST
another question diego, how do you update your system?
Comment 7 diego brizuela 2013-11-20 07:30:59 EST
libcomps not installed on my system, just install it

I update a with fedora 19 to fedora 20 netwok fedup
Comment 8 Ales Kozumplik 2013-11-20 07:53:47 EST
ok, its a fedup problem then.
Comment 9 Will Woods 2013-11-20 12:34:55 EST
No, it's an upgrade problem. All fedup does is install packages; you are responsible for making sure your packages handle upgrades cleanly.

For example: if the timer needs to be activated on upgrades, then you need to handle that in a %pre/%post script.

Or: if there's missing dependencies, then you need to change your package dependencies to avoid that.

Fedup can provide ways for you to fix these problems, but it's not responsible for fixing upgrade problems in other packages.
Comment 10 Ales Kozumplik 2013-11-21 02:44:15 EST
the issue of timers was a false suspect, we cleared that up with the plumbers team.

The libcomps dependencies are not missing, they've been in f20 since late August. And they're correctly flagged in the dnf.spec:

Requires:	python-libcomps >= %{libcomps_version}

Yet the users don't get it installed on their systems, see comment 7.
Comment 11 Will Woods 2013-11-21 12:41:58 EST
Works fine here: 

[    28.057] (II) fedup.cli:inst_open_file() installing libcomps-0.1.4-4.fc20.x86_64.rpm (382/1300)
[    28.139] (II) fedup.cli:inst_open_file() installing python-libcomps-0.1.4-4.fc20.x86_64.rpm (741/1300)

Can you attach your fedup.log and upgrade.log?
Comment 12 Ales Kozumplik 2013-11-21 16:41:14 EST
it might or not be relevant that DNF is an Anaconda dep now (but so are indirectly libcomps, hawkey and librpeo).
Comment 13 diego brizuela 2014-06-23 21:33:57 EDT
after fedup you need install libcomps

Note You need to log in before you can comment on or make changes to this bug.