Bug 1031349 - Useless error message
Useless error message
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 23:26 EST by Dmitry Moskowski
Modified: 2013-11-18 06:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 06:02:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Moskowski 2013-11-16 23:26:12 EST
Description of problem:

There is some stupid error message "need more than 1 value to unpack"

Version-Release number of selected component (if applicable):
Name        : firewalld
Arch        : noarch
Version     : 0.2.12
Release     : 6.fc18

How reproducible:
[root@megatron ~]# firewall-cmd --permanent --zone=public --add-port=9830
need more than 1 value to unpack

Actual results:
Useless, annoying error message

Expected results:
Verbose error message, saying me: "hey, you have forgot to specify protocol in add-port statement! Example: 9830/tcp"
Comment 1 Jiri Popelka 2013-11-18 06:02:43 EST
Should be fixed in firewalld-0.3.7-1.fc18 which has been in stable since 2013-11-06.

Note You need to log in before you can comment on or make changes to this bug.