Bug 1031468 - Project default Copy Trans options cannot be changed
Project default Copy Trans options cannot be changed
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-CopyTrans, Component-Persistence (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: 3.2
Assigned To: Carlos Munoz
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-17 22:58 EST by Carlos Munoz
Modified: 2014-02-18 01:48 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2-SNAPSHOT (20131120-0038)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-18 01:48:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Munoz 2013-11-17 22:58:48 EST
Description of problem:
A user is not able to modify the default project copy trans options because of a NonUniqueOjectException.

Version-Release number of selected component (if applicable):
3.1 (maybe earlier)

How reproducible:
Always

Steps to Reproduce:
1. Log in and head to a project where the user has maintainer privileges.
2. Click on Copy Trans Options.
3. Modify the options
4. Click save.

Actual results:
An error is shown on screen.

Expected results:
The options are saved and a nice info message is shown.
Comment 1 Carlos Munoz 2013-11-17 23:05:28 EST
This was caused by caching some hibernate entities in the view-scope. Solved it by removing that caching, and letting second level cache deal with that.
We should consider making the merge method from session/entity manager visible in the DAOs as this would have been another possible solution.

See:
https://github.com/zanata/zanata-server/pull/278
Comment 2 Ding-Yi Chen 2013-11-19 19:34:22 EST
VERIFIED with Zanata version 3.2-SNAPSHOT (20131120-0038)

Note You need to log in before you can comment on or make changes to this bug.