Bug 103148 - guile is broken on ia64
guile is broken on ia64
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: guile (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 00:13 EDT by Bill Nottingham
Modified: 2014-03-16 22:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-27 10:59:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2003-08-27 00:13:13 EDT
Attempting to link against it:

gcc -I../../../src/gnc-module -I/usr/include/glib-1.2 -I/usr/lib/glib/include
-O2 -g -pipe -Wall -Wunused -o .libs/test-load-c test-load-c.o 
../.libs/libgncmodule.so
/usr/src/build/298107-ia64/BUILD/gnucash-1.8.5/src/core-utils/.libs/libcore-utils.so
-L/usr/lib /usr/lib/libgwrap-wct.so
-L/usr/src/build/268233-ia64/BUILD/guile-1.6.4/libguile/.libs
/usr/lib/libgwrap-glib.so /usr/lib/libguile.so /usr/lib/libguile-ltdl.so -lcrypt
/usr/lib/libglib.so /usr/lib/libltdl.so -ldl /usr/lib/libpopt.so -lm
/usr/lib/libguile-ltdl.so: undefined reference to `__ctype_b_loc@GLIBC_2.2'
/usr/lib/libguile-ltdl.so: undefined reference to `dlopen@GLIBC_2.2'

guile-1.6.4-8.1, presumably (whatever's in the build root.)
Comment 1 Bill Nottingham 2003-08-27 00:41:38 EDT
guile was rebuilt in dist-10 last week; AFAIK, those libs shouldn't end up like
that.
Comment 2 Bill Nottingham 2003-08-27 00:53:07 EDT
Rebuilding fixes it. Any idea how it got built wrong last week?
Comment 3 Phil Knirsch 2003-08-27 10:59:51 EDT
Known strangeness of the current toolchain. I have the same problem with
ethereal which i can't compile on ia64 anymore because of something very similar
and someone else in our office here reported the same for another library
related package (don't remember which one).

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.