Bug 103152 - [GLIBC AS2.1] Zoneinfo data for Europe/Tallinn is incorrect.
Summary: [GLIBC AS2.1] Zoneinfo data for Europe/Tallinn is incorrect.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: glibc   
(Show other bugs)
Version: 2.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 87937
TreeView+ depends on / blocked
 
Reported: 2003-08-27 07:24 UTC by Fred New
Modified: 2016-11-24 14:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-19 17:49:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:359 normal SHIPPED_LIVE Updated glibc packages fix various issues 2003-12-19 05:00:00 UTC

Description Fred New 2003-08-27 07:24:21 UTC
Description of problem:

  The file /usr/share/zoneinfo/Europe/Tallinn contains out-of-date information.

Version-Release number of selected component (if applicable):

  glibc-common-2.2.4-32.8

How reproducible:  always


Steps to Reproduce:
1. date
    
Actual results:  Wed Aug 27 08:52:20 EET 2003
EET indicates Estonian Standard Time.

Expected results:  Wed Aug 27 09:52:20 EEST 2003
EEST indicates Estonian Summer Time.

Additional info:

This problem was previously reported for RHL 7.2 (bug 76549).

This bug was caused by a change in Estonian law to start using Daylight Time
again.  We have been using Daylight Time for two summers now, but updates to
glibc-common continue to distribute bad data.

Red Hat Linux versions 7.3 through 9 work correctly.

Comment 1 Jakub Jelinek 2003-09-03 10:15:12 UTC
This is fixed in RHEL3/Rawhide by splitting tzdata package from glibc-common
(with separate sources), so that erratas to tzdata can be released independently
from glibc erratas.
For RHAS2.1 you can either temporarily copy the appropriate zoneinfo file
from newer distributions, or wait for next glibc rpms, which probably won't
happen for a few months unless some severe bug is discovered.

Comment 2 Fred New 2003-09-03 10:31:48 UTC
This is acceptable.  We've been using the zoneinfo file from a newer
distribution, but I wanted to make sure that future updates of glibc are correct
for RHAS2.1.  Feel free to close this bug if future updates are handled.

Comment 3 Jakub Jelinek 2003-09-29 10:22:07 UTC
Should be fixed in glibc-2.2.4-32.9.

Comment 4 Suzanne Hillman 2003-10-08 19:45:37 UTC
Exists as a errata-candidate, adding to U3 blocker bug list.

Comment 5 John Flanagan 2003-12-19 17:49:36 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-359.html



Note You need to log in before you can comment on or make changes to this bug.