Bug 1031537 - The gear cost infomation on my applications page should be displayed for only 1 time when user have multiple domains.
The gear cost infomation on my applications page should be displayed for only...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Management Console (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
:
Depends On:
Blocks: 1038523
  Show dependency treegraph
 
Reported: 2013-11-18 04:00 EST by Yujie Zhang
Modified: 2015-05-14 21:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1038523 (view as bug list)
Environment:
Last Closed: 2014-01-29 19:50:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
confused gear cost info with multi domains (55.42 KB, image/png)
2013-11-18 04:00 EST, Yujie Zhang
no flags Details

  None (edit)
Description Yujie Zhang 2013-11-18 04:00:10 EST
Created attachment 825434 [details]
confused gear cost info with multi domains

Description of problem:

Create 3 domains and create several applications in each domain, check the gear cost informaion on the my applications page, found that, the gear cost infomation of the account will be displayed 3 times besides each domain. Since it's the gear cost information of the whole account, then no need to bind it to domain display, it pretty much looks like it's the gear cost of each domain. So for user with multi domains, either we only display the gear cost information for one time, or we display the gear cost of each domain.

Version-Release number of selected component (if applicable):
devenv_4043

How reproducible:
always

Steps to Reproduce:
1.Create 3 domains and create 1 application for each domain
2.Go to my application page and check the gear cost information
3.

Actual results:

The gear cost information was displayed for 3 times besides each domain, it looks like it's gear cost of each domain, see the screenshot.

Expected results:

Either we only display the gear cost information for one time, or we display the gear cost of each domain.

Additional info:
Comment 2 openshift-github-bot 2013-11-19 16:32:07 EST
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/7cbec643e24a5e7194e9b63e2c986b97041fcdb2
Bug 1031537 - show gear usage for account once
Comment 3 openshift-github-bot 2013-11-19 16:32:10 EST
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/0cef62a15d886ffb06a674247f45206bd211704e
Bug 1031537 - show gear usage for account once
Comment 4 Yujie Zhang 2013-11-20 03:01:34 EST
Tested on devenv_4052, gear cost information will be displayed for only one time when user has multi domains, so verify this bug, thanks.

Note You need to log in before you can comment on or make changes to this bug.