Bug 1031545 - Syntax check mechanism should be there, while giving sub-directory authentication
Syntax check mechanism should be there, while giving sub-directory authentic...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-nfs (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Niels de Vos
storage-qa-internal@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 04:28 EST by Anil Shah
Modified: 2016-01-29 07:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 07:30:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anil Shah 2013-11-18 04:28:33 EST
Description of problem:
Syntax check mechanism should be there to while giving sub-directory authentication 

Version-Release number of selected component (if applicable):
glusterfs 3.4.0.43.1u2rhs

How reproducible:
Everytime

Steps to Reproduce:
1. [root@rhsauto001 ~]# gluster vol set dist-rep2 nfs.export-dir "/test(10.70.36.240)| (10.70.36.236),/subdirqa(10.70.36.240)"

volume set: success

2.
3.

Actual results:
Gluster command executes successfully.

Expected results:

Gluster command should display message like "Syntax error"

Additional info:

[root@rhsauto001 ~]# gluster v i
 
Volume Name: dist-rep2
Type: Distributed-Replicate
Volume ID: 65a2f89e-7d92-4632-b10e-bfc7119a8f9a
Status: Started
Number of Bricks: 6 x 2 = 12
Transport-type: tcp
Bricks:
Brick1: 10.70.36.236:/rhs/brick1/d2r12
Brick2: 10.70.36.237:/rhs/brick1/d2r22
Brick3: 10.70.36.236:/rhs/brick1/d4r12
Brick4: 10.70.36.237:/rhs/brick1/d4r22
Brick5: 10.70.36.236:/rhs/brick1/d6r12
Brick6: 10.70.36.237:/rhs/brick1/d6r22
Brick7: 10.70.36.231:/rhs/brick1/d1r12
Brick8: 10.70.36.233:/rhs/brick1/d1r22
Brick9: 10.70.36.231:/rhs/brick1/d3r12
Brick10: 10.70.36.233:/rhs/brick1/d3r22
Brick11: 10.70.36.231:/rhs/brick1/d5r12
Brick12: 10.70.36.233:/rhs/brick1/d5r22
Options Reconfigured:
nfs.export-dir: /test(10.70.36.240)|(10.70.36.236),/subdirqa(10.70.36.240)
nfs.export-volumes: on
nfs.acl: on


[root@rhsauto001 ~]# rpcinfo -p
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100005    3   tcp  38465  mountd
    100005    1   tcp  38466  mountd
    100003    3   tcp   2049  nfs
    100024    1   udp  42334  status
    100024    1   tcp  58970  status
    100021    4   tcp  38468  nlockmgr
    100021    1   udp    949  nlockmgr
    100227    3   tcp   2049  nfs_acl
    100021    1   tcp    951  nlockmg
Comment 3 Soumya Koduri 2016-01-29 07:30:22 EST
Since gluster-nfs shall sooner be deprecated, please check nfs-ganesha and file a RFE against it if required.

Note You need to log in before you can comment on or make changes to this bug.