Bug 1031606 - Windows 2008 ODBC Driver works but throwing exceptions on Teiid Server
Windows 2008 ODBC Driver works but throwing exceptions on Teiid Server
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.0.0
x86_64 Windows
unspecified Severity medium
: ---
: ---
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 06:37 EST by Filip Nguyen
Modified: 2013-12-05 08:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 07:17:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server log (39.70 KB, text/x-log)
2013-11-18 06:37 EST, Filip Nguyen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-2744 Blocker Closed Windows 2008 ODBC Driver works but throwing exceptions on Teiid Server 2015-09-03 05:44:29 EDT

  None (edit)
Description Filip Nguyen 2013-11-18 06:37:15 EST
Created attachment 825552 [details]
server log

When running ODBC driver on windows, the querying works but weird WARNinig is showed in the server console. See the attachment.
Comment 2 Mladen Turk 2013-11-18 07:27:34 EST
You should also try 64-bit version. That's the natural environment for 64-bit windows.
Comment 5 Filip Nguyen 2013-11-18 11:34:48 EST
Ok.

(In reply to Mladen Turk from comment #2)
> You should also try 64-bit version. That's the natural environment for
> 64-bit windows.
Comment 7 Filip Nguyen 2013-11-18 11:39:02 EST
Mladen, in fact, this was tested on 64 bit windows, using the x86_64 installer. I am not sure why it shows os arch 32 bit in the server log actually.

(In reply to Mladen Turk from comment #2)
> You should also try 64-bit version. That's the natural environment for
> 64-bit windows.
Comment 10 JBoss JIRA Server 2013-11-19 10:12:49 EST
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2744

How is a warning a blocker?
Comment 11 JBoss JIRA Server 2013-11-19 10:12:50 EST
Ramesh Reddy <rareddy@jboss.org> made a comment on jira TEIID-2744

Run with the debug on server and provide the exact SQL statement being handled by the ODBC layer. Or log.
Comment 14 Filip Nguyen 2013-11-20 07:17:36 EST
The problem is exhibited only with loopback translator. Probably problem with metadata. When I tried to query some different datasource with different translator, it works ok. Closing this.
Comment 15 JBoss JIRA Server 2013-11-20 07:18:12 EST
Filip Nguyen <fnguyen@redhat.com> updated the status of jira TEIID-2744 to Resolved
Comment 16 JBoss JIRA Server 2013-11-20 07:18:12 EST
Filip Nguyen <fnguyen@redhat.com> made a comment on jira TEIID-2744

The problem is exhibited only with loopback translator. Probably problem with metadata. When I tried to query some different datasource with different translator, it works ok. Closing this.
Comment 17 JBoss JIRA Server 2013-12-05 08:55:59 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-2744 to Closed

Note You need to log in before you can comment on or make changes to this bug.